Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My suspend has always worked but stopped doing so yesterday. The days before I fiddled around a bit with Xorg, but I have reverted all those changes already. What I was working on was vaapi support and installed xbmc. I also updated Xorg from the Ubuntu repository yesterday. I tried to manually downgrade the updated packages which I got from /var/log/apt but resuming from suspend would still not work.

I have a Lenovo E320 with a Sandy Bridge chipset. After A suspend the screen stays back, CTRL+ALT+F1 / F7 don't do anything. I even put a script into /etc/pm/sleep.d/ which writes into /var/log/wakeup but it does not print anything. Putting the lid down again doesn't put the laptop into suspend again.

I put the computer to sleep 15:55, woke it up 15:56 and force shut it down 15:57 by long pressing the power button. Then 15:58 I restarted it. This is the resulting syslog: http://pastebin.com/ih9CKb0t

I will provide any other logs required!

Thank you very much for your help, Fred

share|improve this question
    
This thread has some good suggestions albeit 11.04: askubuntu.com/questions/61495/… – chrisjlee Feb 9 '12 at 6:05
up vote 1 down vote accepted

It seems it was a hardware fault. Lenovo changed my mainboard and RAM and now it works (with the same hard disk image).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .