Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Specifically, I'm on a Dell Inspiron 1525. I'd like to disable the touchpad so that I can re-enable if my mouse were to run out of batteries (so physically breaking the connection to the motherboard or uninstalling the driver will not be the best options). In the Control Panel, when I go to "Mouse" and find the touch pad, there is no disable option. Any ideas?

Edit: I am on Windows 7. There is a driver on the Dell site that might allow an option to disable it, but I cannot install it on Windows 7.

share|improve this question

migrated from serverfault.com Jan 28 '12 at 17:35

This question came from our site for professional system and network administrators.

    
I have a ThinkPad .. I love the eraser and do not like the touchpad. I find myself hitting the touchpad accidentally when typing and moving the cursor! When I upgraded to Vista it took me a while to get the correct driver and the utility program that let me disable it. –  tomjedrz Jun 19 '09 at 18:11
    
Eraser for teh win ^^ Even setting the touch pad to a scrolling area is pretty much useless - there's a lot more control in the Eraser while holding the middle button for scrolling... love Thinkpads without touchpads. –  Oskar Duveborn Jun 19 '09 at 18:58
    
On my thinkpad, Fn+F8 enables or disables the touchpad. Really handy ! –  petrus Jul 22 '10 at 21:27
add comment

12 Answers

  1. Right click the touchpad icon in the system tray (it looks like a monitor with a flash green dot)
  2. Pointing device properties -> Devices tab,
  3. Touchpad - click Disable
  4. Touchpad buttons - click Disable
  5. Click Disable Touchpad/Stick when a USB pointing device is present.
  6. Click Apply
  7. Click OK.
share|improve this answer
    
Forgot to mention I am on Windows 7. I don't see touchpad icon in the system tray like in XP. –  sestocker May 15 '09 at 1:23
add comment

You can try downloading the Windows Vista drivers for your mouse/touchpad

http://support.ap.dell.com/support/downloads/driverslist.aspx?os=WLH&osl=EN&catid=17&impid=-1&servicetag=&SystemID=INS_PNT_PM_1525&hidos=WLH&hidlang=en&TabIndex=

It ought to work for Windows 7. When I upgrade my Windows Vista to Windows 7 Beta or RC, it retained the Vista drivers.

The touchpad driver should then provide a Dell Touchpad systray icon that allows you to Disable Touchpad / Pointing Stick when external USB mouse is present.

share|improve this answer
add comment

I finally got my Dell laptop track pad disabled.

I loaded Windows 7 64 bit onto a new 320 GB drive in my Dell Latitude D620 laptop, and I have been frustrated with the inability to disable the trackpad.

I tried looking it up 6 months ago and gave up, and I have been dealing with it ever since. The original drive had all of Dell drivers and stuff already installed on it. But Windows 7 doesn’t. So tonight I thought I’d give this another try and went to the BIOS and disabled it there, but it still continued to work.

I then went to Dell's website and downloaded the input device Alps Pointer for my laptop so that I could get the driver back into my laptop. I then installed the driver inspite of the fact that Windows said there is a known issue with this driver. I clicked on the lookup issue on the Internet but nothing happened. So I went ahead and installed it anyway.

After I installed it I went to the control panel, then clicked on Hardware and Sound, then clicked on the mouse tab and the interface for the track pad and pops right up under the device tab. Here you can enable or disable the pointing stick and the touch pad. It works great for me and my mouse is still functioning just fine.

Finally after 8 months I have fixed this issue and hopefully it will work for you.

share|improve this answer
add comment

Try searching the registry for this: DisableTouchPadIfMousePresent

If it exists, simply change the value from 0 to 1. If the change is not immediate restart, and see if that helps.

share|improve this answer
add comment

Many laptop models have options in the BIOS for you to disable pointing devices. Not sure if the 1525 does or not (I hate Dell's web site...)

share|improve this answer
add comment

You can install the Dell driver on Windows 7 using the compatibility mode. I used the Vista Service Pack 2 mode, and it went just fine. And the option to disable the touchpad works well.

share|improve this answer
add comment

Under Linux on my netbook I use syndaemon to disable the touchpad responding to clicks while I'm typing, which gives almost the best of both worlds.

http://code.google.com/p/touchfreeze/ seems to be a Windows implementation of the same idea, though I have not got around to trying it yet so can't comment on how well it works.

share|improve this answer
add comment

I found a great way:

  1. Install the latest touchpad drivers from the Dell website.
  2. Drag the mouse icon from your control panel onto your desktop.
  3. Right click on the newly created shortcut and then click 'properties'.
  4. Click on the 'short cut' tab.
  5. In the shortcut key box press the letter m (without the commas) and then it should change to something like 'Ctrl + Alt + M'.
  6. Now whenever you would like to disable the touchpad just click on 'Ctrl + Alt + M'.
  7. The mouse properties will appear.
  8. Under the 'device settings tab' you can disable the touchpad.
  9. Use the same key press to reenable the touchpad.
share|improve this answer
add comment

No No No. there are no sites that can help you disable your touch pad! After spending almost 20 hours gping from site to site and writing it all down (whew), I finally called Sony directly and 45 minutes later Vavoom, the nightmare is over. I realize their are many well intentioned people out there and to them I give cudo's. but for me not having my cursor jump all over the place and jumbling up all my typing, all I can say is Sony---1-800-222-7669! good luck to all of you and happy holiday's.

share|improve this answer
add comment

Because it's a Dell, you don't have a button to disable the TouchPad and also a mouse will work without any further drivers needed and it doesn't tell you anything about a driver. I have a Inspiron 1545 and had the same issue. After 20 min of google I found this solution ( like 2 years ago ). Just install Synaptics Pointing Device from here http://www.synaptics.com/resources/drivers and after that restart your laptop. Then look for the icon that shows a TouchPad in the Notification Area in the right corner of the screen ( next to the Time/Date, Speakers, Battery ), double click on it, go to Device Settings tab, look for something that uses PS2 port and press the Disable button. You can always reactivate the TouchPad from there also. Problem solved ( the easier way ).

share|improve this answer
add comment

Install the Synaptics driver from the Synaptics site.

You will get Palm Detection, Disable when other pointer is connected, and 3-finger gesture options (for all mice of the last ten years).

share|improve this answer
add comment

I had problem disabling the buttons belonging together with the touchpad on a new ThinkPad running Windows 7, as I prefer to use only the pointing stick and the buttons belonging together with the pointing stick - not the touchpad or the two buttons belong together with the touchpad.

Here is the solution I have tried and figured out (step by step):

  1. Please make sure your pointing stick and the buttons next to it are all working.
  2. Go into Windows "Control Panel"
  3. Double-click "Mouse"
  4. Under "Device Settings" tab, Select "Synaptics TouchPad V7.2", click on "Enable" button
  5. Click on "Settings"
  6. Click on "Buttons"
  7. On the right-hand-side of the window, uncheck the checkbox "Enable buttons".
  8. Click on "OK".
  9. Then click on "Disable" to disable "Synaptics TouchPad V7.2".
  10. Click on "OK".

Now you have the touchpad and the buttons associated with it disabled.

For a strange reason, disabling the touchpad does not automatically disable the buttons associated with it. You need to go through above steps to achieve this very simple goal.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.