Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I configure a number of forwarder ports on my home router for RDC

3389 -> Windows Vista desktop : 3389

3390 -> Windows Vista laptop : 3389

3391 -> Windows 2008 server : 3389

3392 -> Windows 2008 server : 3389

All was working fine until I swapped my laptop for another with Dell. After setting up the new laptop, I enabled Remote Desktop as usual, firewall disabled, but cannot connect to it from the outside Internet. I tried rebooting my router, changing the router port to 3388, to no avail. The other computers still connect fine. Nothing to do with Network level authentication either.

I can only RDC to the laptop from the LAN. Any ideas what may be the problem?

share|improve this question
    
Forwarding on router is configured for specific IP within network, perhaps new laptop got new IP? –  superego Sep 9 '09 at 13:10
    
They are all static IP addresses. –  icelava Sep 9 '09 at 13:16
    
how did you do the port-forwarding in the router? Some routers do port-forward to IP addresses, some do portforwarding to hostnames –  caliban Sep 9 '09 at 13:34
    
it is by IP addr. i use the same IP addr 192.168.1.7 for the laptop. –  icelava Sep 9 '09 at 14:00

4 Answers 4

If IP is statically assigned maybe your router has the filtering by MAC address switched on. Different laptop = different MAC address of network card.

share|improve this answer
    
the router has the new laptop's MAC address in its ARP table; there is no MAC address filtering. –  icelava Sep 9 '09 at 13:59

Did you change the listening port on the new laptop? Follow this KB article for instructions:

KB 306759

share|improve this answer
    
No, it's a new laptop and I did not adjust that; it is still 3389 which i can connect fine within the home LAN. –  icelava Sep 9 '09 at 13:27

Turn the firewall back on and try again and I would also check what options you have set for RDP if you are mixing XP and Vista/Win7 modes.

share|improve this answer
up vote 0 down vote accepted

Turns out McAfee Security Center firewall was blocking the port. The version on this laptop is slightly different from my older laptop's and I did not immediately realise there was another feature page that specifically blocks/unblocks ports for untrusted networks (i.e. Internet).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.