Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I followed instructions at here and now I get the following error when I ran vm:

vm-imap-protocol-error: IMAP protocol error: "unexpected char (10)"

$ lsb_release -rd
Description:    Ubuntu 11.10
Release:    11.10
$ apt-cache policy vm
  Installed: 8.1.0-1
  Candidate: 8.1.0-1
  Version table:
 *** 8.1.0-1 0
        500 oneiric/universe i386 Packages
        100 /var/lib/dpkg/status
$ apt-cache policy stunnel4
  Installed: 3:4.35-2build1
  Candidate: 3:4.35-2build1
  Version table:
 *** 3:4.35-2build1 0
        500 oneiric/universe i386 Packages
        100 /var/lib/dpkg/status
share|improve this question
up vote 1 down vote accepted

There has been a bug report on it. And the solution was to add the following line in .emacs -

(setq vm-stunnel-program "/usr/bin/X11/stunnel4")
share|improve this answer
Can I do it in ~/.vm? – qazwsx Jan 29 '12 at 21:45
Tried this in .emacs but still get the same error. – qazwsx Jan 29 '12 at 21:57
It works now!!! Thank you! – qazwsx Jan 31 '12 at 0:07
What are the changes did you make between? – Bibhas Jan 31 '12 at 4:41

I just tried this on OSX, and it worked for me, after some IMAP URL wrangling.

What do you have in your .emacs and your .vm? In particular, what are your vm-imap-account-alist and vm-primary-inbox set to?

And, as mentioned by @Bibhas, you need to have a working stunnel program. You can download latest from stunnel.org1

share|improve this answer
I made a typo and put stunnel in my .vm but stunnel4 in my .emacs. After correcting, everything works. Thank you! – qazwsx Jan 31 '12 at 0:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .