Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use VMWare workstation and have had no problems with my virtual machines and bridging the network card. However, I installed Virtualbox to check it out and ever since I can't establish a network connection with my virtual machine network cards being set as "bridge".

I did find I could set them to NAT and get a network connection with the nic card.

Obviously, a possible answer would be to uninstall VirtualBox, but maybe I don't have too, and there is an answer.

I have tried unsuccessful the following to get bridging to work...

  • Uninstalling / Re-installing VMWare tools

  • Uninstalling / rebooting / re-installing network card

  • I have even tried giving nic card static IP and related DNS/Gateway server

Has anyone else experienced this problem or know a solution other than removing VirtualBox?

share|improve this question

1 Answer 1

I had this issue also. I figured out that VMBox installes it's own network driver or something like that. When VMWare tries to bridge the network it makes automatic choice.. Obviously wrong. So you have to manually specify which driver it has to load.

I'm using VMWare Workstation.. Thus you go to View->Virtual Network Editor, the first interface in a list would be VMnet0 bridged. You'll see "Brigged to" list below which should be set to Automatic. Switch it to your physical card, not VMBox net adapter..

Then restart you VM, or type "service network restart" in terminal..

share|improve this answer
    
you're my savior –  armel Jul 13 '12 at 11:07
    
Great tip. Thank you! –  mbonaci Jan 1 '13 at 23:11
    
Just a quick fyi, in VMWorkstation 9, the Virtual Network Editor is located in the Edit menu. –  JoshP Jun 19 '13 at 12:16
    
Another way to fix this is disable the vmware bridge protocol for the vbox network adapter using the Network and Sharing Center. –  Wimmel Jun 16 at 7:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.