Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I would like to send plain text emails using Apple Mail. (I'm using version 3.6 on Leopard.) This looked fairly straightforward: Preferences -> Composing -> Message Format: Plain Text. However, Apple Mail sends messages using this MIME type:

Content-Type: text/plain; charset=ISO-8859-1; format=flowed; delsp=yes

Most email clients will display very wide lines using this format, and I'd rather keep my lines within 75 columns or something like that.

In essence, I would like Apple Mail to send messages using this MIME type:

Content-Type: text/plain; charset=ISO-8859-1

Any hints?

share|improve this question

1 Answer 1

If you happen to send ALL your messages as plain text and ALL using the same encoding, then maybe adding a custom header allows you to overwrite any value Mail sets.

Like, not tested:

defaults write com.apple.mail UserHeaders \
  '{"Content-Type" = "text/plain; charset=ISO-8859-1"; }'

As you may have seen while testing: Apple Mail actually wraps the text in the message source, before sending it. So it's indeed the "format=flowed" part that makes the recipient flow those lines back into the original paragraphs.

(I actually dislike messages that are NOT flowed, and would actually leave it to the client to disable it. And I love the way Apple Mail sends very feature-limited HTML mails. Apple Mail only uses HTML when really needed, and even then hardly adds any formatting -- for example: it does not force some default font size upon the recipient when I just happen to put some word in bold. So I actually switched my default from plain text to Rich Text. But: that's a matter of taste, I know.)

share|improve this answer
    
Yeah, I think I will want to send HTML emails from time to time. Thanks for your explanations. –  Luís Oliveira Sep 10 '09 at 16:01
    
I've tried to find some hidden settings for Mail.app, but maybe the debug info (object file) is missing on my Snow Leopard Mac, as I cannot get it to work. An example on how to do it for Finder (not working for my Mac either) can be found at arcticmac.home.comcast.net/~arcticmac/tutorials/… I also used the old way on a Leopard machine, thus strings - /Applications/Mail.app/Contents/MacOS/Mail > ~/Desktop/mail-strings.txt but didn't find anything that looks like a hidden setting either. Also no template on the file system holding Content-Type or flowed... –  Arjan Sep 12 '09 at 14:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.