Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Toshiba satellite P25-S607 laptop, which works fine in general, but has one issue where the clock runs fast. For example, after running for a day or two, the clock will be ahead 2 hours or more (if it's 3pm, it will show 5pm - or worse).

I do not receive an error that the battery is bad when powering it up.

It's running XP Pro (fully patched) and I have only tested with it sitting on 24/7.

Any ideas?

share|improve this question
3  
Are just hours wrong or are minutes and seconds problem too (only hours cold indicate time-zone switching problems)? Check your time synchronization settings, it could happen that the computer is connecting to a bad time server. If the RTC itself is bad, you'd probably get much smaller problems with time, unless it's very damaged. –  AndrejaKo Jan 30 '12 at 13:36
3  
What OS, and is that running a day or two without reboots or power cycling? –  Paul Jan 30 '12 at 13:41
    
^ yes what os. in XP or 7 you can increase the ammount of times that time sync (with a time server) occurs to workaround it. there was a single fix for "quartz.dll" in xp that fixed the system clock getting offset. in 7 you can get more time syncs going in the task scheduler. At any rate you should check Time Syncs in XP you can see it in "internet time" in the clock stuff, in 7 you can check for time syncs in event viewer. time syncs do not work if the time is offset to far, compounding the issue. –  Psycogeek Jan 30 '12 at 14:15
add comment

1 Answer

Sounds like it has a busted clock. To make sure, go into the bios and check the time, then shut it off for the night. Come back in the morning, and go straight back into the bios. If the clock is off, then it's got to be the hardware.

share|improve this answer
    
Update: So far, it keeps time perfectly having it plugged in, but turned off. If I go in to the bios, the time is perfect, even after a week of sitting turned off but plugged in to A/C. I am going to boot to windows xp now and not run anything, but just let it idle and see what happens, update later. –  Scott Szretter Feb 6 '12 at 16:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.