Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using windows 7, I cannot connect to a shared network drive on another machine.

  1. I can ping the machine.
  2. I can remote desktop connect to the machine.
  3. The machine is on the same subnet
  4. My friend with the exact same laptop as me (and on the same network, same workgroup) can connect to the shared folder.
  5. The machine I am trying to connect to and my friends machine can both see shared folders on my machine.
  6. I also cannot see shared folders on the friends laptop.
  7. When I select diagnose, windows tells me nothing useful.
  8. When I select see details on the error pop up, I see: Error code: 0x80004005 (google doesn't help much)
  9. I can nbtstat -a the machine who has the shared folder.
  10. When I try with my firewall turned off the same happens.
  11. I have ensured my windows 7 has all updates.
  12. I run security essentials to ensure my laptop is clean.
  13. I run ccleaner to clean up my registry. Same error.
  14. I have tried with my laptop on both wireless and ethernet.

As you can imagine, I am banging my head against the wall on this one.

share|improve this question

10 Answers 10

up vote 5 down vote accepted

Right finally this to work. Firstly, I am putting down everything here I tried that didn't work as it might also be of use to someone. If you have the same problem as I described here, you should do everything here.

In Control Panel \ Network and Internet \ Network Connections \ My Connection \ Properies:

  • I ensured Link-Layer Topology Discovery Mapper I/O Driver was enabled
  • I ensured Link-Layer Topology Discovery Responder was enabed Tried with
  • I tried with IPV6 enabled / disabled

In Control Panel \ All Control Panel Items \ Network and Sharing Center \ Advanced sharing settings and I checked relevant settings in "Home or Work profile".

  • I ensured: "Turn on network discovery" is set
  • I tried both security settings in "File sharing connections"

In Control Panel \ All Control Panel Items \ Network and Sharing Center

  • I wnsure my network was marked as a "Work" network. Ensure this is correct for you.

Ok so none of the above yielded any luck.

Then, I did the following:

At, Control Panel \ All Control Panel Items \ System

I selected: "Computer Name" tab.

  • I entered something in the computer description text box. This was blank.
  • I selected the Change... button.This gives you the opportunity to change the Workgroup name Mine was "WORKGROUP". I set it to something else and then set it back to WORKGROUP. The thinking was this might flush something.

I then logged onto the machine that had the folder I wanted to share thru RCP. Then I accessed a share folder on my PC. Now, when this session was alive, I opened up Computer Management and I opened the "shared folders" and sessions and saw the computer I was trying to connected, connecting to me.

Again the thinking was this would flush something out. After, I did all this it worked. I am not sure exactly what step fixed it. I was under too much time pressure to keep checkeding after I changed anything.

Thanks for all who helped out here.

share|improve this answer

Maybe it's a little too late to answer this, but I solved this issue in this way:

Go to start, run, type services.msc and press enter.

When you are on the services applet make sure the service "Workstation" is running and is set to start atomatically.

Hope this helps more people looking for a solution.

share|improve this answer

I had to reinstall my OS and immediately i could have full access to my network share

As I installed programs I kept checking accessibility to my share.

It turns out that Brother installed a printer monitor for the HL-2270DW that when turned off allowed access to my NAS.

Too bad I had to do a reinstall to locate the problem.

share|improve this answer

0x80004005 = Access Denied.

Double check your login name and password (credentials) to ensure they match on both the computer you are connecting from and the one you are attempting to connect to.

Then ensure the account/credentials are given access to both the share itself and the folder that's shared.

share|improve this answer
    
As stated I don't even get to the credentials stage. –  dublintech Jan 31 '12 at 9:45
    
@dublintech So, you're logging in with a username/password that also exists on the target machine, and the account on the target machine has permission to the share and the folder? I'm not sure what 'credentials stage' you are expecting? Perhaps edit your question and include the exact error message you receive. –  Ƭᴇcʜιᴇ007 Jan 31 '12 at 13:12
    
I don't even get to specify my user name and password. I open up a windows explorer and type \\themachine and then I get the error. –  dublintech Jan 31 '12 at 13:43

The frustrating thing about Windows, even Windows 7, is that it caches your account credentials SOME WHERE for these types of network accesses. If the credentials to access the remote machine changed, it is possible that Windows is still referring to the old credentials.

One thing you might try is changing the remote machine's name and / or IP address (this assumes Windows is storing credentials on a per-machine name or per-IP basis). If credentials are required, it SHOULD ask for a new set of credentials when you try to access the new name or IP.

Another possibility is that you / your user (whatever you are logged in as) does not have share permissions on the remote machine, folder, drive, whatever. Make sure those match too!

Last but not least, does your friend have his laptop sharing properly?

share|improve this answer
    
I don't even get to the stage of being asked for credentials. Another friend can connect to the machine that I can't. He has no permissions that I don't have. –  dublintech Jan 31 '12 at 9:45
    
Anyone else got ideas for this - really stuck... –  dublintech Jan 31 '12 at 11:39

You said you have Microsoft Security Essentials installed. I had a very similar problem and wrote a tutorial with a simple fix I found: disable the Network Inspection System which seems to cause conflicts with simple network sharing features.

Fix Problem with Homegroup Computers not Being Available

I hope this fixes your issue.

share|improve this answer
    
Thanks. I tried this but it did not work. Same error. Any other ideas? –  dublintech Jan 31 '12 at 9:45

I had a similar but different problem. QNAP TS410 NAS. This is a Linux based network RAID array. Two Win 7 machines, one could access the shared drives on it, the other could not. problem turned out to be DNS related. Two networks with a VPN between them. NAS and two PCs on one network and the Domain Controller on the other. Had to set Domain Controller's IP as the first entry in DNS within the network adapter properties on the problem machine.

share|improve this answer

I encountered the same problem and got 0x80004005 when I was connecting to server. I spent hours and hours struggling with it. At last I found the solution.

Here are my steps:

Network and Sharing Center->Change adapter settings
->Right click on you connection->Properties.

Make sure Client for Microsoft Networks have been installed. If not, use the Install button to install it.

enter image description here

I hope this can help you.

share|improve this answer

Dont know if its too late for this, but I found a solution in my case. I ended up enabling all the sharing options under "Change advanced sharing settings" I then right clicked on my computer then hit the manage button.

This brought me into Computer management, i then expanded the shared folder, then clicked on the shares section. This did alot of things for me, it allowed me to redefine an absolute list of sharing folder (i had a lot of sharing folders stuck in limbo, which I could now unsure). I right clicked on the drive i was having issues with, in my case E: drive. This opened up drive properties. I clicked on the Security tab, then clicked on the Edit button.

this brought me to a permissions section. I the add button, then added a user called "guests" press ok, then goe down to the permissions section and click allow on everything.

*warning, dont do this if your computer is on a shared network, IE other random people that join consistantly as this opens it up to anyone"

Also, if you just wanted one computer to connect, IE your laptop to your desktop (you desktop being the computer that is sharing the drive) then add the name of your laptop to this list.

push ok, ok, ok, ok ok ok ok then ok one more time for measure, and you should have full control of that particular drive.

share|improve this answer

I had the same issue, and while on the client machine (the one trying to access the network files) I had to remove/re-add the credentials using the credential manager. Note that both the host and client machines use the same OS (Win7 Ultimate, how 64, client 32) witht he same username and password (full usernames are different as the machine names are different and there is no AD/Server environment).

Once I removed and re-added the credentials, it all worked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.