Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to get my crappy desktop (with Windows XP) to be a web server. When I go to localhost it displays the website just fine, but when I go to the external IP on another computer it displays "mikrotik routeros 4.11 configuration page". I've forwarded port 80.

Port forwarding (not sure if I did it right):

enter image description here

Microtik page that is displayed:

enter image description here

I disabled my firewall but it's still not working.

share|improve this question
    
how do you configure the site? –  Mughil Jan 31 '12 at 4:41
    
Have you put Wamp online? –  Bibhas Jan 31 '12 at 4:43
    
The site is just an html page, and yes WAMP is online. I can go to localhost on the computer and it displays the website correctly. –  ahota Jan 31 '12 at 4:49
    
How have you determine what your external IP is? What ever IP you are going to, it doesn't seem to be your airstation, so I suspect you are hitting someone elses router. –  Paul Jan 31 '12 at 5:09
    
Google and whatismyip.org both give me the same IP address. Is there a more reliable way? –  ahota Jan 31 '12 at 5:23

2 Answers 2

up vote 0 down vote accepted

If you've put WAMP online, and forwarded the port from router, and turned off remote management feature of the router, then it should be done by now. If it's not, then something else is on the way. If your global IP is forwarding you to Mikrotik page, then that means there is a mikrotik device on your network above your Router that's managing the traffic. maybe another router at the higher level. is it your Office network? or some shared network?

share|improve this answer
    
It's on my home network. –  ahota Jan 31 '12 at 14:59
    
Are you aware of any Mikrotik device? Like a local router of your ISP or something? –  Bibhas Jan 31 '12 at 18:20

You're going to have to move the router's administration interface to a different port such as 8000 or 8080.

share|improve this answer
    
How do I do that? I have a Buffalo WHR-G54S. –  ahota Jan 31 '12 at 6:22
1  
Most likely, you can't, and so you can't use port 80 for the web server. –  David Schwartz Jan 31 '12 at 6:36
    
Better choice is forward another WAN port to local Apache. If port presence in URL isn't nice - redefine default http for domain (or host) in question with SRV –  Lazy Badger Jan 31 '12 at 16:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.