Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've looked at:

http://www.superuser.com/questions/22952/installing-windows-7-on-a-dual-boot-machine

and

http://www.superuser.com/questions/16098/how-can-i-get-my-ubuntu-boot-manager-back-after-windows-7-install

The bottom line is, after a Windows 7 install, the only way I could get the Ubuntu LiveCD (or FreeBSD, or Debian, or Ultimate Boot CD) to boot, was to unplug the SATA cable on the Windows partition (I was lucky to have more than one HDD).

Why?

--

EDIT (2009-10-20):

The issue is purely academic now, since I used my "unplug drive" workaround last month. I've put a bounty on this because I want to know for my own benefit, and unplugging a drive is not a feasible solution. Thank you to everyone who has contributed to this question. I value your input.

share|improve this question
    
Added the links for you. Good luck. –  th3dude Oct 20 '09 at 12:29
    
Thanks - this was before I could add more than one link :) –  user3463 Oct 20 '09 at 19:39
    
When you say "with Windows 7 installed" - does this mean you used to be able to do it with Vista/XP, and now with Win7 installed you can't? As is mentioned in several answers below, the boot device decision is made in the BIOS, long before Windows is even loaded, and I am doubtful it is Win7's fault. –  Jared Harley Oct 25 '09 at 17:59
    
Hi Jared. That's exactly right - I was able to boot between Windows 2008 Server, Ubuntu and FreeBSD. Windows 7 RC came along, and the events as played out above and below occurred. –  user3463 Oct 25 '09 at 21:10

4 Answers 4

up vote 2 down vote accepted
+75

When you have more then one hard drive, cdrom, etc you only get so many choices to boot from even if you select them properly in the linked image. Make sure the drive you want to boot from is on the top when in the cdrom/hard drive menu.

You can have the First Boot Device CDROM but then have two CDROMs under the boot menu and it's choosing your bluray instead of your DVDRW or however you may have it set up. Unplugging it was probably what brought the correct one to the top.

share|improve this answer
    
Thanks for the suggestion, but I checked that too. I spent hours messing with this. –  user3463 Sep 9 '09 at 15:18
    
Interesting then make sure to let everyone know once you figure it out. –  user10547 Sep 9 '09 at 22:33
    
I plan to, believe me :). As I commented lower down in the page, this is probably a conflict between the BIOS and the Windows 7 boot sector. I will look for another BIOS update, but I did one recently when this problem first appeared. Thanks for your suggestions so far. –  user3463 Sep 11 '09 at 11:46
1  
The BIOS loads well before any part of Windows 7 does. I'd double check the boot priority again and also get a new Ubuntu CD. You may just have a bad burn. –  MDMarra Oct 20 '09 at 12:15
1  
Although off topic .. I had a similar problem with XP this week. I selected boot from USB device, but it kept booting from the Hard Drive, even after I disabled the Hard drive boot in the BIOS. The problem for me was that there was another (un-bootable) hard drive on a USB port. The boot system seemed to see that, fail to boot, and then go for the internal hard drive regardless. Removing that drive and only having a single device on USB solved my problem –  Peter M Oct 20 '09 at 20:36

Erm... feel a little bit silly to ask this question, but have you set your optical drive (DVD drive) to be the first device in your PC's boot priority? In short, have you set or selected your optical drive with the Ubuntu CD to be the first to boot?

Find the boot priority settings in your BIOS.

alt text

share|improve this answer
1  
Yes, I did that :). There's no such thing as a silly question. –  user3463 Sep 9 '09 at 14:46
    
@Randolph Potter : Okay great - by the way, some SATA optical drives have issues booting if they are not connected to the first two SATA ports. Did you try switching the optical drive SATA port to the first port (check your mobo manual), and then try again? –  caliban Sep 9 '09 at 15:05
    
The optical drive is IDE. The motherboard is an Intel P35. –  user3463 Sep 9 '09 at 15:15
    
Ah okay, now is your com's SATA set to AHCI? or is it "Compatible" or something? Try changing this setting to see if it works? –  caliban Sep 9 '09 at 15:35
    
It is set to AHCI. I tried changing to the compatible mode and that made no difference either. I even tried sorting the order of the three SATA drives and that didn't help. –  user3463 Sep 9 '09 at 16:21

Have you tried booting using a USB-based storage device ? You can take almost any .ISO file and set it to make a USB device bootable with it. UNETBOOTIN, which can run under both Windows and Linux can take a .ISO file of any Linux distribution and make your USB storage device bootable with this ISO file, just as if you were booting off a CDROM. If you cannot boot off a CDROM, this may be an alternative solution.

JF

share|improve this answer
    
Good suggestion, but it didn't work. I tried it with the Ultimate Boot CD, as well as a Knoppix USB stick. –  user3463 Oct 20 '09 at 19:34

This is very odd though as the BIOS settings override any OS settings. Windows 7 is not even loaded at the point where the BIOS selects from which medium to load the desired OS from.

I do understand that (all?) Windows versions have always destroyed any bootloader e.g. LILO or GRUB and replaced it with its own. In this case I always installed first Windows and then another OS if needed.

In your case though, you are trying to boot from a CD or DVD which really should be invoked prior to Windows 7 having anything to say.

I suggest you edit the BIOS setting and simply set CD/DVD as the first and only boot option. Then disable the rest (2nd,3rd,4th, etc) boot options. That setting will work fine as a HD is really not required for the system to boot (from a CD/DVD).

If anything else fails, are you sure the media is not corrupted?

  • Try to download another distribution to see if that also fails.
  • Try to use a different writer.
share|improve this answer
    
I did all you suggested last month, and none of them worked. I even replaced the DVD writer. The media, as I've pointed out, was several different types, including Ubuntu, FreeBSD, Debian (and Knoppix on a USB stick). –  user3463 Oct 25 '09 at 21:08
    
You may have another hardware issue. I once had a similar issue with only the CD drives not working properly. It was a faulty motherboard (IDE controller) even though no other issues were experienced on the box. –  mr-euro Oct 26 '09 at 7:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.