Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running VMWare Workstation 7 on Windows 7 x64. In the guest OS (also Windows 7 x64) I have VMWare Tools installed, but the VMWare Tools service is disabled. I run the VM in full screen mode and the VMWare toolbar at the top often displays this tooltip:

To release input, press Ctrl+Alt

This tooltip obscures a part of the VM (often the menu of a program I'm using) and it's annoying as hell. Going out of full screen mode and into it again gets rid of it, but only until I mouse over that toolbar and then it reappears! How do I get rid of it, once and for all?

I tried adding

hints.hideAll = "TRUE"

to the .vmx file for the VM and to preferences.ini and neither of those helped.

share|improve this question

2 Answers 2

I fixed this by going into Workstation Preferences and unselecting "Grab keyboard and mouse input on mouse click".

Then, restart the workstation. Obviously, VMware tools would need to be installed on the guest.

share|improve this answer
I know I know, old thread -- anyone know what the change this causes in the .vmx file? – JustJeff Oct 15 '14 at 13:21
@JustJeff I don't think it would cause any change, it chages the vmware preferences (probably in the registry). – peterh Jun 11 at 11:15

This never worked for me using the vmware workstation interface, but you can do it using an HEX editor and modiyfing vmware.exe, so here's how I did it on Workstation 11.

HxD is a good one for windows.

  • First, create a backup/copy of your vmware.exe file in program files.

  • Close vmware workstation.

  • Open HxD as an administrator and open vmware.exe.

  • Once the file is open, search for the ascii string (CTRL+F) To release. It should be between the offsets 0012A350 @ 0012A390.

  • Replace the following bytes by 00 (ascii null) or 2E (ascii .):

    @&!*@*@(msg.vmui.fullScreen.ungrab.tooltip)To release input, press %s

Caution! Do not delete any bytes, replace them. The file must stay the same size.

share|improve this answer
Hint for VMWare Player (Version 7.1.0) is the file vmclientcore.dll. – Maxime Poulin Jul 7 at 17:58
Between the around 5 different workarounds I've found on the net, this was the only working one. – peterh Jul 11 at 22:35
worked like a charm. thx – termnml Jul 22 at 8:56
This is way harder in v12. First off, note, you need to move the files to a safe location, not the desktop (for some inexplicable reason) for HxD to allow you to write. Then the messages are now stored in vmwarecui.dll and vmclientcore.dll Search for To return as the message has been changed. The code is also different, just start at the @& and replace to the end of the message. But their is also more messages that take over when this one is removed, so just scan up and down a few lines in both files for similar messages, in both files, and null those out as well. – Jonathon Wisnoski Nov 5 at 14:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.