Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Windows 7 with 3 drives, C, F,G.

  • C holds windows on an SSD (120 GB)
  • F is a RAW device that has a truecrypt container (1 TB)
  • G is a RAW device that has another truecrypt container (500GB)

I encrypted the drives today with the method "Encrypt a non-system partition/drive" and mounted F-->D and G-->E and I could access my data via the D and E drives fine. It worked well all day long. I rebooted my machine and I get this message:

Loading Operating System ... 
Missing operating system 

Windows fails to boot. I didn't encrypt the system (C drive) where windows resides. Do you know what the problem could be? My machine was working fine after I encrypted the D and E, it just won't boot now. If I boot my machine into Ubuntu from a USB flash drive I can see my C drive and all the files just fine so I know it's not corrupt.


I tried Startup Repair from the Windows 7 DVD and chose to automatically repair and then got this message after a few minutes:

Startup Repair cannot repair this computer automatically

If I select to go to a command prompt, I can see the C drive and all my files. What should I do now?


I booted into gparted and examined the partitions. I noted that one of the partitions where my D drive data is stored (the 1TB drive) had the boot flag set. I unset the boot flag and made sure that the 500GB drive was unset (it was) and the 120G SSD drive boot flag was set (it was). I rebooted and now get a different message:

Loading Operating System...

BOOTMGR is missing
Press Ctrl+Alt+Del to restart

I also posted this Q to the truecrypt forum.

share|improve this question
up vote 2 down vote accepted

That your SSD holds the Windows system doesn't necessarily means that it is the boot device.

First you should check which HDD/SSD is specified as boot-device in the BIOS.

Second you should check if the SSD contains the 100MB Windows 7 boot partition. This partition usually contains the Windows boot manager. This partition also has to be active for boot.

Third you should make sure if the SSD contains a valid Master Boot record (MBR). You can rewrite a new MBR by starting from the Win7 DVD and execute on the repair command prompt

bootrec.exe /FixMbr

See also: How to use the Bootrec.exe tool in the Windows Recovery Environment to troubleshoot and repair startup issues in Windows

share|improve this answer

I don't think truecrypt has anything to do with your problem. I have an SSD too and sometimes a disk check needs to be run and files get repaired. Try booting from your Windows 7 DVD and do an automatic repair.

share|improve this answer
As mentioned in my question I already did an automatic repair. – Mark Allison Jan 31 '12 at 9:24
Can you start Checkdisk (chkdsk) from the DVD? – ZippyV Jan 31 '12 at 9:30
I physically unplugged the SATA cables from my spinning disks and then rebooted into the Startup Repair again. This time windows offered to fix problems. I rebooted and Windows loaded. I then rebooted and plugged the drives back in, and all is fine. Only took me three hours to figure out... – Mark Allison Jan 31 '12 at 9:47
As Zippy pointed out. While the program surface with the drives plugged in, the process of encrypting them was not the direct cause, for some reason your drive was set to the boot drive. When you unplugged he drives the repair utility was able to guess ( and since it had zero choices ) which drive was the boot drive and thus your problem was solved. The good news is you figured it out. – Ramhound Jan 31 '12 at 12:17

Did it actually encrypt the volume? You can use the recovery CD and hit F8 and then option 4 to restore the previous boot manager which will probably be the windows one. Then reboot with the CD out of the computer and try again.

share|improve this answer
Can you explain what 'Option 4' is to the OP? – Canadian Luke Oct 8 '15 at 17:48

I would try checking which drive it is trying to boot from in the BIOS settings, or booting the computer with just the SSD connected (disconnect the two HDs). I suspect the BIOS is trying to boot from the wrong drive. At the very least, doing this would remove some variables from the equation.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .