Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On Windows, Ctrl-Alt is mapped to Alt Gr, but not so on Linux.

Using Alt Gr for 3rd level keys is wrist-killer nr. 1! I'm unable to find a workaround that doesn't remove other functionality I use (the few mapping options in keyboard settings). I found references for other with the same problems (plenty of Europeans..), but I haven't found a single acceptable workaround.

Has anyone found a way to map Ctrl-Alt to Alt Gr?

BTW: I've mapped left Alt for 3rd level keys, and disabled Alt Gr (which makes Alt Gr behave like regular Alt). This works, but it makes between Windows and Linux (or other workstations) a lot harder.

share|improve this question
    
What do you mean by 3rd level keys? Do you mean characters in the shift state activated by AltGr? –  Piotr Dobrogost Sep 28 '13 at 19:48
    
Do you mean in X11 or on the Linux virtual console? –  pilona Oct 15 '13 at 1:42
    
@pilona: X11, but the question is two years old. I'm now using programmer dvorak, so this is no longer an issue for me. –  simendsjo Oct 16 '13 at 9:19
    
@simendsjo What about question in my comment? –  Piotr Dobrogost Nov 25 '13 at 20:43
    
@PiotrDobrogost I'm not familiar with the terminology you use. The keys have 3 symbols on them. One is default when pressing it, one is enabled using shift, and one enabled using altgr. IIRC, there are 5 levels you can access in total. As noted above, I'm now using programmer dvorak, and I've bound a key as the composite key so I can also type "special" characters like æøå. –  simendsjo Dec 7 '13 at 12:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.