Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My eclipse no longer shows line numbers, its configured to do and it did before

(I believe it became like this after I moved its application folder, mac osx)

The settings read that it's supposed to show line numbers but the right click menu on the left strip where line nums are displayed shows that "Show Line Numbers" is not ticked, clicking it changes nothing.

Any conf files or settings I must go through to force line numbers again?

I think since this is happening only for perl .cgi files, Eclipse considers them binary and doesn't work the same way. How to overwrite that? It's perfectly fine in linux.

share|improve this question
up vote 1 down vote accepted

As long as you haven't moved your workspace folder, this is weird. However, if you have set up your workspace inside the application directory, than it looks obvious to me again, because Eclipse may not find it's (moved) settings.

Go to your workspace folder. You should find a .metadata directory. In here search for .plugins/org.eclipse.core.runtime/.settings/org.eclipse.ui.editors.prefs.

To enable line numbers look for a line like


Try adding it if it doesn't exist.

If your workspace folder is inside your application folder you should think of moving it to a different place, e.g. Documents in your home folder - I'm also on a mac and have a ~/Projects for those things. Inside here I have workspacefor my Eclipse work. After moving you have to enter the path on first start of eclipse.

Also make sure it's writable.

share|improve this answer
I think it finds them in that config file I saw the spiteful undo buffer setting at 9000 (which Mac ignores of course) I see this setting in the preferences window in eclipse itself. The line numbers line is in the config. – Recct Feb 21 '12 at 10:57
But yes I have moved my folder and it still doesnt show them. It shows line numbers for other source files, CSS html you name it just not CGI. (perl) Is there a setting to show line numbers for binary files, I think eclipse considers them binary. – Recct Feb 21 '12 at 10:59
Ah, for perl... are you using EPIC? – Karsten S. Feb 21 '12 at 19:51
Oh well.. there is no additional setting regarding epic. Perl should text file not binary. However, you may check which editor is being used when you open a cgi file. You can add an additional file extension so that cgi files are opened with your (perl?) editor plugin. – Karsten S. Feb 21 '12 at 21:30
Yeah I did that after those edits i made to my answer but didn't fix the issue. Yes, Perl EPIC – Recct Feb 22 '12 at 10:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .