Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to run a 32-bit executable on my 64-bit Ubuntu. Here a short overview of the situation. But I have to prepend ia32 libs are installed:

> aptitude search ia32
i   ia32-libs - ia32 shared libraries for use on amd64 and ia64 syste

First of all I tested the filetype:

> file tipp10
tipp10: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.4, not stripped

I am using 64bit Oneric, with the not so recent kernel, because I didn't restart it yet.

> uname -a
Linux christchurch 3.0.0-14-generic #23-Ubuntu SMP Mon Nov 21 20:28:43 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

As I said normal execution doesn't work. It aborts with file or directory not found.

> strace ./tipp10
execve("./tipp10", ["./tipp10"], [/* 46 vars */]) = -1 ENOENT (No such file or directory)
dup(2)                                  = 3
fcntl(3, F_GETFL)                       = 0x8002 (flags O_RDWR|O_LARGEFILE)
fstat(3, {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 2), ...}) = 0
[...]

Here is the ldd output on my system. On my 64bit Debian Server the programm is reconized as a dynamic linked programm and a few lib references can be seen in the output. But on my Ubuntu:

> ldd tipp10
    \tdas Programm ist nicht dynamisch gelinkt
# german for: "The programm is not linked dynamic"

I don't understand what is going on.

share|improve this question
    
Interesting case, installing 'ia32-libs' actually solved it for me - ie, I'm able to run 32bit apps natively, sans virtualization. Maybe try running sudo aptitude reinstall ia32-libs? –  user38584 Jan 31 '12 at 19:59
    
Reinstalling didn't work. I had one warning: /var/lib/dpkg/info/ia32-libs.postinst: 40: /usr/lib32/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders: not found . But this doesn't look related. –  mkkl Jan 31 '12 at 20:36
    
Indeed it isn't. Are you using oneiric? (Reason I ask is, if you're using an upcoming release, things may be broken out of the box, hence why it isn't recommended to use prereleases of ubuntu) –  user38584 Jan 31 '12 at 22:15
    
It is definitely oneiric (10.11). –  mkkl Feb 3 '12 at 10:40
add comment

1 Answer

up vote 1 down vote accepted

Check that you have libc6-i386 correctly installed; ENOENT from execve suggests a missing dynamic linker.

share|improve this answer
    
Was installed, but a reinstall fixed it. Thank you very much. –  mkkl Feb 3 '12 at 10:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.