Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm an emacs newbie trying to make the switch; after configuring org-mode to my liking (my primary reason for switching) the next thing I wanted to do was customize the colors. I know several people have asked about getting emacs color-theme to work, but I've been searching for over an hour and so far the instructions haven't helped me so please bear with me.

I'm using GNU Emacs for OSX from here on 10.6.7.

Most instructions on the web say to start by running

sudo apt-get install emacs-goodies-el

If I were running linux that'd be no problem, but Macs don't have apt-get that I know of so I'm trying to figure out what to do instead.

I found a copy of color-theme.el and the themes/ folder in a tarball here and put it in my emacs.d/ directory. Then I added the boilerplate stuff to my init.el file:

(setq load-path (append load-path (list "~/.emacs.d/themes")))
(setq load-path (append load-path (list "~/.emacs.d/color-theme.el")))

(require 'color-theme)
(color-theme-initialize)
(color-theme-robin-hood)  

But when I load emacs I am still getting this error:

File error: Cannot open load file, color-theme

My questions

  • Are there other things besides color-theme contained in emacs-goodies-el that are needed for color-theme to work properly on Mac?
  • If so, where can I download these files and install them without apt-get?

Thanks for your help.

share|improve this question

3 Answers 3

up vote 3 down vote accepted

color-theme.el is not being developed so you may want avoid that.

Instead I suggest you to download Emacs 24.0.XX pretest version from that website. So you can simply call M-x customize-themes to change new inbuilt themes.

More over emacs 24 has its own package manager so you dont need to apt-get to install emacs packages. once you install Emacs 24, call M-x list-packages to see the available packages.

share|improve this answer

I'm not familiar with the structure of emacs-goodies, but if you look up the document of load-path, you'll find that it's a list of directories, not files. So I'm not sure if your second setq is helpful. Try removing it.

And in general, if you want to install some Emacs extension, just download it and put it somewhere. Then add that directory to your load-path. Depending on the extension, you may need to require it or write some autoloads. I believe Emacs 24 has package support built in, but I haven't tried it yet.

And finally as others have mentioned, Emacs 24 has built-in theme support. It's better to use that instead of color-theme, if you are using v24 (who's not, right? :-)

share|improve this answer

I was in the same boat as you. I would avoid using 24 until it's stable. Instead, as Darksair stated, your load-path is supposed to point to a path (directory), not a file.

Follow these steps:

  1. Download the gz file from the link you listed above

  2. Move the file to your directory

    %> mv ~/Downloads/color-theme.el ~/.emacs.d/
    
  3. Add the path and settings to your emacs resource/profile/settings file

    %> emacs ~/.emacs
    [type]    (add-to-list 'load-path "~/.emacs.d/")
    [type]    (require `color-theme)
    [type]       (color-theme-initialize)
    [type]       (color-theme-robin-hood) 
    {save} Ctrl+x Ctrl+s
    

For a more complete install, download the tarball and copy over the following contents to your .emacs.d/

  • color-theme.el
  • color-theme-autoloads.el
  • themes/
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.