Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need to connect to a client's server through VPN.

I'm using Windows 7 but the VPN from the client is compatible only to Windows XP. I installed a VM (Windows XP) on my Windows 7. After I installed the VM I connected to the VPN of the client.

When I did so, I started a remote desktop connection in order for me to connect to their server. Once I connected to their server, I needed to copy a file to my local machine.

When I right click the file from the server and click on copy, it worked. But when I paste it on the desktop of my virtual machine, the paste is greyed out.

How do you copy a file from a remote desktop connection using a VPN?

share|improve this question
add comment

4 Answers 4

up vote 1 down vote accepted

You can also download freeware like FTP. Designate the location of files for copying and pasting, and it works (for IT guys who deal with servers).

share|improve this answer
add comment

When you open the RDP client (but before you connect), click on "Options". Then select the "Local Resources" tab, click "More" at the bottom, and select the check boxes for the local drives you want to share/have access to. Then connect as usual.

When you open "My Computer" on the remote server, you'll now see a new option - "C on [yourcomputername]" or similar. You can now copy to and from your local machine.

Not quite as easy as copy and paste, but it works.

share|improve this answer
    
thanks for your quick reply. But I tried this and I got the message that it's not possible to connect because there is someone logged on to the console... But I will try this again tomorrow. When you say RDP is this my VM win xp? –  tintincutes Jan 31 '12 at 22:44
    
RDP client = mstsc.exe –  Al Kepp Feb 1 '12 at 0:24
    
@Al Kepp: Does this mean that I have to type in the mstsc.exe in the Server or on my VM win xp? –  tintincutes Feb 1 '12 at 7:26
1  
@Jim G: Actually, once you do this, you will be able to copy and paste files between the remote desktop window and your local machine. –  rob Mar 3 '12 at 8:39
add comment

Here’s a handy tip I just recently learned from the new intern on our team (see, you can learn something from anyone on any given day). I’ve long known you could access your local drives from a remote machine.

  • Start up a remote desktop dialog.
  • Then expand the dialog by clicking on Options, then check the Local Resources tab.
  • Make sure Clipboard is checked, and then hit the More… button.

Now you can select a local disk to be shared with the remote machine.

For example, in this case I selected my C: drive.

As you can see the file explorer has another drive named xyz which can be used to copy files back and forth from my local machine to the remote machine.

But, here’s the part I did not know:

Let’s take a look at the desktop of my remote machine, which has a text file named info.txt:

  • One way I can get that file to my local machine is to copy it to the mapped drive we saw in the previous screenshot.

  • Or, I can simply drag and drop the info.txt from my remote desktop machine to a folder on my local machine.

So all this time, I had no idea cut and paste operations for files work across remote desktop. This may be obvious for many of you, but it wasn’t to me. :)

share|improve this answer
    
@zackrspv Great edit, thanks. Please note the spammy appearance though, including the link in the answer (which I've now removed) and the user profile. –  slhck Feb 1 '12 at 22:26
    
Ah, sorry forgot to catch that; trying to get better w/ these edits ;) –  zackrspv Feb 1 '12 at 22:28
    
@zackrspv You're doing a great job, keep 'em coming! –  slhck Feb 1 '12 at 22:33
add comment
  1. Size your Remote Desktop Window
  2. Copy the file from your Remote Desktop.
  3. Click on a location on your target PC and then paste it. It works even when you have no admin rights.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.