Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Yesterday I mistakenly made a factory backup on my external hard drive from my Lenovo ThinkPad T-420. It wasted my whole empty space on that hard drive.

Now I want to make another Lenovo factory backup on a 16 GB USB drive or a DVD, but it never allows me to create a backup. When I click on the Lenovo recovery drive, it gives me the following message every time:

You can have only one copy of the Microsoft Window Operating system. The Product Recovery Media Creator will exit now.

share|improve this question

3 Answers 3

#include "obligatory DRM rant"

Lenovo, in their infinite wisdom, have changed how they store the fact that the recovery image has already been created in newer versions of their recovery software. Amusingly they have not bothered to correct the "Microsoft Window" typo as well!

Process Monitor reveals that recovburncd.exe reads the file Q:\FactoryRecovery\RECOVERY.INI:DONE before bugging out. The colon indicates the use of an alternate File Stream. After a recovery image has been created, this stream contains the string 1\r\n. Deleting the stream does not work, but replacing the stream contents with the string 0\r\n works. This can be done from the command prompt:

echo 0 > Q:\FactoryRecovery\RECOVERY.INI:Done
share|improve this answer
1  
On my X220 you must edit service_done.ini and put DONE=0 –  sw. Sep 5 '13 at 21:39
    
This needs many more upboats! +1 –  George Sep 6 '13 at 10:39
    
Thank you very much! –  МикроПингвин Mar 8 at 4:57

Try this – source: mossarch4u.blogspot.com

Lenovo - You can have only one copy of the Microsoft Windows operating system.

Lenovo notebooks come with Factory Recovery Disks creation software. This allows you to create recovery disk in case you want to re install the notebook other than from the local hard disk. You can create the recovery discs on CD/DVD, memory disk or USB hard disk.

Attention: The USB hard disk will be formatted and you loose all the data!

It takes a long time to prepare the creation of the recovery media. Everything is copied into c:\swshare before then it gets copied to the external source you selected.

You can do this only one time! If you want to create the recovery disks more than once, you get a message:

You can have only one copy of the Microsoft Windows operating system. The Product Recovery Media Creator will exit now.

This is the workaround for this problem:

All you need it in the Lenovo_Recovery disk. In my case its drive letter Q:\ If i click on this drive in the explorer it show you nothing cause the content is hidden!

  1. Open the Explorer and then click Organize -> Folder and search options
  2. In window Folder Options click tab View
  3. Now enable Show hidden files, folders, and drives and then click OK The option of Hide operating system files should be made unchecked and then you'll be able to see the files.
  4. Click on the Lenovo_Recovery drive, in my case drive Q:\
  5. Here is every thing needed to create the recovery disks!
  6. Edit the file FactoryRecovery\service_done.ini
  7. Change the string DONE=1 to DONE=0 and exit the editor saving the changes
  8. You can now recreate the Factory Recovery Disks

Have fun, always backup data before restoring any disks!

share|improve this answer
1  
Iain, it is important that you 1) use blockquotes for stuff you didn't write yourself, and 2) cite the source of the original text. Failing to do so is not only against the etiquette here, but also causes copyright issues. –  slhck Feb 1 '12 at 13:50
    
thanks a million! thou, I needed to select "show operating system files". –  Little Bobby Tables Apr 24 '12 at 13:46
    
dosn;t work. no such file –  yura Aug 23 '12 at 9:04
    
check below answer. It works –  HaKr Dec 6 '12 at 20:50

I was following Sam Morris' method but found not luck. However, the way he found his solution inspired me and helped me to find my solution on my ThinkPad T400 bought back in 2009.

The quick answer is: change the value of the registry entry, HKCU\Software\Lenovo\Factory Recovery\done, to 0. For my case, the Q:\ drive was never altered to turn on the forbidding flag. It was totally done through this switch in your system's registry.

For people with patience on reading how I found out, this is how. I also use Process Monitor to track what recovburncd.exe did after launching (up to the point where there was only the "Cancel" button for me to terminate it). So I tried to identify (within the activity list in Process Monitor) which activity prevented recovburncd.exe from enabling the "OK" button. Then, I saw the registry entry mentioned above had value 1, reminding me of the similar terminologies in the other two ways (Sam Morris' method and the service_done.ini method) of fixing the "done" flag. It was a bingo!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.