Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an old Athlon 800Mhz PC with a Matrox G450 video card here that is used for watching DVD and video, for most part it works quite fine, but every two seconds the video playback stops for a fraction of a second. It's a tiny but noticeable and annoying glitch.

CPU usage doesn't seem to be the problem, there isn't any major IO going on in the background and no obvious background process that could be causing this. Starting the playback with 'nice' or a larger cache (mplayer -cache ...) didn't bring any improvements.

The machine is running Ubuntu 9.04, under Windows98 the problem does not appear and video is fluent.

What could be the cause of this problem and how could I try to debug this further? My current guess would be that its hardware/irq related issue, but thats pretty much just a blind guess.

Edit: The problem seems to have disappeared, sadly I have still no idea what solved it or what caused it in the first place.

share|improve this question
1  
Out of curiousity, copy one of the .VOB's to your harddisk, and try playback from there. –  Breakthrough Sep 9 '09 at 16:51
    
Tried that, didn't change anything. –  Grumbel Sep 15 '09 at 3:22
add comment

4 Answers

Which output driver are you using?

mplayer -vo xv

might solve your problem.

share|improve this answer
add comment

Boy, there are a lot of dials on mplayer.

That machine should be plenty fast enough. Peltier's advice is good, as is that in the comment to try the file on known fast media (maybe you aren't getting the most out of you media drive in linux). You might also check on the real-time clock interrupt rate (read the docs, but it involves reading and/or manipulating a file under /proc), the preprocessing level (-vf pp -autoq and similar), and the audio sync limits (-autosync 20 or whatever).

Remember that mplayer will look in several places for configuration options:

  • a global configuration file at /etc/mplayer or /usr/local/etc/mplayer or /opt/etc/mplayer or ...
  • a user specific config file usually at ~/.mplayer. Here you can also have movie specific configuration files.
  • command line arguments which could be effected by any shell alias's you've defined for mplayer.
share|improve this answer
add comment

Next time it happens, check what IO mode your DVD device is on. You can do it with hdparm. It probably should be about udma2, anything less then pio4 might cause this freezing.

share|improve this answer
add comment

I used to play DVDs on my Athlon-900 / G450 all the time. It sounds exactly like the symptom of having the DVD reader in non-DMA mode. (Yeah, it's tough to diagnose!)

As you note, there's plenty of CPU for playing a DVD there -- it's the device latency in PIO mode that kills you. It might have been an unrelated upgrade that changed the config to use DMA mode, since (if DMA workS) there's no benefit to running your DVD on PIO.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.