Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can i configure my wpa_supplicant.conf? I am using OpenWRT in my TP-link WR841N in mode STA. But I can not connect to SMC ! I want connect to SMC by wpa_supplicant! But I know it's possible in other configuration. My final objective is connect to eduroam (corporate, school, etc networks look like)

wlan0     Scan completed :
      Cell 01 - Address: 00:13:F7:E4:E3:B7
                Channel:6
                Frequency:2.437 GHz (Channel 6)
                Quality=37/70  Signal level=-73 dBm
                Encryption key:on
                ESSID:"SMC"
                Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                          12 Mb/s; 24 Mb/s; 36 Mb/s
                Bit Rates:9 Mb/s; 18 Mb/s; 48 Mb/s; 54 Mb/s
                Mode:Master
                Extra:tsf=0000000e397f7181
                Extra: Last beacon: 100ms ago
                IE: Unknown: 0003534D43
                IE: Unknown: 010882848B960C183048
                IE: Unknown: 030106
                IE: Unknown: 07064E4C20010D14
                IE: Unknown: 2A0100
                IE: Unknown: 32041224606C
                IE: IEEE 802.11i/WPA2 Version 1
                    Group Cipher : TKIP
                    Pairwise Ciphers (1) : CCMP
                    Authentication Suites (1) : PSK
                   Preauthentication Supported
                IE: WPA Version 1
                    Group Cipher : TKIP
                    Pairwise Ciphers (2) : TKIP CCMP
                    Authentication Suites (1) : PSK


//My wpa_supplicant.conf

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0

network={
    ssid="SMC"
    key_mgmt=WPA-PSK
    proto=RSN
    pairwise=TKIP
    group=TKIP
    psk="secret passphrase"
}

//And in my /etc/config/wireless

config 'wifi-device' 'radio0'
    option 'type' 'mac80211'
    option 'macaddr' 'f8:d1:11:51:0a:2a'
    option 'hwmode' '11ng'
    option 'htmode' 'HT20'
    list 'ht_capab' 'SHORT-GI-20'
    list 'ht_capab' 'SHORT-GI-40'
    list 'ht_capab' 'TX-STBC'
    list 'ht_capab' 'RX-STBC1'
    list 'ht_capab' 'DSSS_CCK-40'
    option 'disabled' '0'
    option 'channel' '6'  #it is correct !

    config 'wifi-iface'
           option 'device' 'radio0'
           option 'network' 'wwan'
           option 'mode' 'sta'
           option 'ssid' 'SMC' 
           option 'encryption' 'none' #I don't if it's correct ?

Thanks for your help :)

share|improve this question
add comment

1 Answer

in wpa_supplican.conf, write as below. remove all....

network={
ssid="SMC"
key_mgmt=WPA-PSK
proto=RSN
pairwise=CCMP
group=TKIP
psk="secret passphrase"
}

use wpa_passphrase for psk generation. You will get one kill. put psk="that key"

Then run with this command

wpa_supplicant -Dwext -i wlan0 -c /etc/wpa_supplicant.conf -dd

change driver and interface name, if it is different.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.