Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need to be able to connect to my client's server from my laptop ethernet port using a cross cable. The server has no attached monitor/keyboard and only has a network card, which carries the following ip setup (for confidentiality, ip address has been changed). The ip setup is provided by the client's network administrator:

Server (win7 pro):

IP address : 10.18.120.20 Subnet : 255.255.255.0 Gateway : 10.18.120.1

In order to connect to the server via RDP, I configure the workgroup on the laptop to the server, and tried to configure the network setting for the network card attached to the cross cable to:

Laptop (win7 home):

IP address : 10.18.120.21 Subnet : 255.255.255.0 Gateway : 10.18.120.1

The network is connected (no errors under network connection) but i'm not able to ping the server nor can i ping my laptop from the server. Also, i can't even ping the server ip (10.18.120.20) from within the server itself! Firewall has been disabled. Please note that my laptop and the server is also connected to my office wlan - in fact i don't use the ethernet lan port.

What have I done wrongly? Thanks.

Additional info:

Tried disabling all other networks, no difference. One thing, on both laptop and server win7, the cross cable ethernet network is shown as "unidentified" and on public mode. I'm not able to change the public to work or home. The link on public is disabled. Also, I can ping the server cross cable assigned ip address from the server itself, while i can't ping the across cable laptop ip address from the laptop. No firewall is enabled.

share|improve this question
1  
Private IP adresses aren’t confidential. –  kinokijuf Feb 1 '12 at 18:15
1  
The workgroup is irrelevant for RDP, no need to mess around with that. Can you verify that the link-light on the Network interface went on when you connected the cable? BTW, if the equipment isn't old, then you don't really need a cross-over cable. –  Zoredache Feb 1 '12 at 18:15
    
@Zoredache - The network works and lights are on. I tried both cross and straight. –  Joshua Lim Feb 2 '12 at 2:21

2 Answers 2

Your subnet mask may be wrong - try 255.255.255.240 you can use a online subnet calculator to work it out. Also, i think you should set the default gateway on one system as the other system's ip address - this setup has worked for me before

If you have a gig-e ethernet adaptor on any one or both ends, you shouldn't need a crossover adaptor.

share|improve this answer

Disable the Wireless on the laptop as a simple test. Rest of your setup looks fine. But be sure the cable is good.

share|improve this answer
    
Thanks, tried disabling all other networks, no difference. One thing, on both laptop and server win7, the cross cable ethernet network is shown as "unidentified" and on public mode. I'm not able to change the public to work or home. The link on public is disabled. Also, I can ping the server cross cable assigned ip address from the server itself, while i can't ping the across cable laptop ip address from the laptop. No firewall is enabled. –  Joshua Lim Feb 2 '12 at 2:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.