Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

At some point my touchpad stopped working on Lenovo x220 under Ubuntu 11.10, after login.

I have found two possible solutions for that online, but neither of them work.

First, gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true and a second one, xinput set-int-prop "SynPS/2 Synaptics TouchPad" "Synaptics Off" 8 0

After looking more carefully into xinput I have realized that xinput list-props "SynPS/2 Synaptics TouchPad" outputs:

Device Enabled (132): 0

This field seems to be stuck to zero, because trying to set it back to 1 by: xinput set-int-prop "SynPS/2 Synaptics TouchPad" "Device Enabled" 8 1 doesn't seem to have any effect, e.g. I still have:

Device Enabled (132): 0

Any ideas? Thank you!

share|improve this question

migrated from stackoverflow.com Feb 1 '12 at 19:31

This question came from our site for professional and enthusiast programmers.

1  
Could you try synclient TouchpadOff=0? –  grawity Feb 1 '12 at 19:37
    
I just tried that and I get a very strange behaviour (after a few seconds it comes back to 1, also the touchpad is not working during these seconds): $ synclient TouchpadOff=0 $ synclient -l | grep Touch TouchpadOff = 0 $ synclient -l | grep Touch TouchpadOff = 0 $ synclient -l | grep Touch TouchpadOff = 1 –  Maria Mateescu Feb 8 '12 at 13:46

3 Answers 3

Try setting org.gnome.settings-daemon.peripherals.touchpad.touchpad-enabled to true with dconf-editor.

(Source)

share|improve this answer
    
Great, this finally worked!! Thank you very much! –  Maria Mateescu Feb 15 '12 at 11:01
1  
@MariaMateescu If it worked, accept the answer by clicking on the tick to the left of the answer. –  Bob Apr 15 '12 at 11:30
    
If you don't have a mouse, run gsettings set org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled true. It does the exact same thing via the command line. –  Arion May 31 '13 at 4:16

Having absolutely the same configuration (Lenovo x220/Ubuntu 11.10) and experiencing the same issue, I've done the following: I checked out what goes out to standard output when i press FN+F8 (Touchpad off shortcut) using:

xinput --watch-props 11

(11 is my device id from "xinput list" command)

What i should get when disabling touchpad:

Property 'Synaptics Off' changed.
Synaptics Off (286):    1
Property 'Device Enabled' changed.
    Device Enabled (132):   0
Property 'Device Enabled' changed.
    Device Enabled (132):   0

What i got this time:

Property 'Synaptics Off' changed.
Synaptics Off (286):    1
Property 'Device Enabled' changed.
    Device Enabled (132):   1
Property 'Device Enabled' changed.
    Device Enabled (132):   1

So it's a list of mutual excluded parameters.

What i did:

xinput --set-prop 11 'Synaptics Off' 0

And everything worked fine after that, even after logout.

share|improve this answer

Try this:

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps
share|improve this answer
    
please try to explain to the best of your ability the command lines you used as answer. also, short answers are non-adviseable, as an explanation of the steps, even if a small one, is seen as healthy behaviour twards future readers. –  Lorenzo Von Matterhorn Mar 25 '13 at 17:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.