Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running yum check-update and it freezes after a 2 lines of output:

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

I'm not sure what is happening. The last things I remember doing with yum were "yum update" and looking at one of the Centos yum repos but I didn't make any changes.

Any suggestions to fix yum?

share|improve this question
up vote 18 down vote accepted

You may have a DNS issue. Try to ensure you can resolve DNS records locally:


If you get an IP back from that command, you should be OK for DNS. Try then removing the fastestmirror cache and re-running your yum command:

rm -f /var/cache/yum/timedhosts.txt

share|improve this answer
I did get an IP back from that command. timedhosts.txt was an empty text file but I tried removing it anyways. I then reran my yum command. Unfortunately no success. It's still hanging at the same place, "Determining fastest mirrors". If I run verbose, I get Loading "fastestmirror" plugin Config time: 0.094 Yum Version: 3.2.22 Setting up Package Sacks Loading mirror speeds from cached hostfile – barrrista Feb 1 '12 at 23:58
To rule out an issue with the fastestmirror plugin, try running yum without any plugins: yum --noplugins check-update – Garrett Feb 2 '12 at 0:23

All of this did not work with me.

Using CentOS and yum. yum hangs without an error message, at least, so it appears. Pressing Ctrl+C does not work (pressing it again and again and again does).

Several things need to be checked: - are the repositories OK? - is networking OK? - are the yum and rpm databases OK?

So, first start with the easy stuff - clean the databases:

rm -f /var/lib/rpm/__*
rpm --rebuilddb -v -v   
yum clean all

If that did not work, you can set a debug level, error level and timeout for yum in /etc/yum.conf:


The timeout is standard 30 seconds. So if a repository does not respond, the error takes 30 seconds to appear. Also try using yum without the plugins (like fastest mirror and priorities) with the option --noplugins. Now starting yum again should give you more info faster. Test with:

yum --verbose --noplugins info

You might get something like this:

 Config time: 0.105
 Yum Version: 3.2.22
 Setting up Package Sacks
 Loading mirror speeds from cached hostfile
 * base:
 * extras:
 * ius:
 * rpmforge:
 * updates: link-to-server-repository/repomd.xml: [Errno 4] IOError: urlopen error (97, 'Address family not supported by protocol') 
 Trying other mirror.

This indicates no information can be received from the server. Try the URL that is displayed by yum (indicated above with link-to-server-repository) in your web browser. Copy&paste it from your yum response, not from this post! If you get a list, you know the repository is online.

If you get an error in your browser, try removing that repository from /etc/yum.repos.d. Try to fetch the list on your server with wget and paste the URL:

wget link-to-server-repository/repomd.xml

If this generates a timeout, then there's a problem with your firewall or proxy settings. Try to disable your firewall.

If you are running csf (ConfigServer Security and Firewall) and lfd you can disable csf with:

csf -x

Try yum again and if it works, you'll have to reconfigure your csf. Enable csf again with:

csf -e

And also check your proxy settings. You can also try to change the https in to http in the .repo files at /etc/yum.repos.d/.

share|improve this answer
Thank you! Rebuilding the db fixed it for me. – Ryan Shillington Aug 29 '13 at 19:56
This answer is worth so much more than 4 upvotes =( – mveroone Dec 11 '13 at 13:11
Lots of good information here. Increasing the debugging level and running yum --verbose --noplugins info led me to find "Error: Cannot retrieve repository metadata (repomd.xml) for repository: base. Please verify its path and try again" which I am investigating now. My DNS is working so that should not be the problem. – harperville Jun 16 '14 at 16:39
An important point that seems to be missing in this answer is that yum check can take hours to complete! More info: – gmas80 Dec 16 '14 at 18:30
First code is what worked with me .. thanks. – Maher Abuthraa Dec 23 '15 at 20:13

I had a similar issue. It turned out to be an old DNS address in resolv.conf. I changed the IP to the correct one, and it fixed the issue.

share|improve this answer
Under Vagrant this can happen too. – bbaassssiiee Feb 25 '15 at 12:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .