Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows XP. When I insert the Visual Studio 2008 DVD, 50% of my dual core Xeon CPU gets pinned by the svchost.exe process.

The DVD never mounts and is never usable. This happens on multiple machines. I have found many similar issues, but only one direct reference to this issue, and no solution is offered.

Help! I need to install Visual Studio.

share|improve this question

5 Answers 5

up vote 2 down vote accepted

As Matthew & Troggy said, if machine hangs when you insert the dvd, it points to one thing: That the DVD is bad. Windows is trying to read it via the DVD Reader & hence hanging the PC. Here, your PC should return to normal if you eject (from the DVD ROM) the DVD.

The only solution is create a new DVD from the ISO image. Else contact the vendor for a replacement CD.

EDIT: In-case one has an ISO image & the DVD ROM is just not ready to relent, just install Alcohol 52, then mount the iso image in the virtual drive. Then run the installer as if you are doing so from you physical DVD ROM. (Cause if you try too much, you may end up spoiling the DVD Writer).

share|improve this answer
    
DVD will not eject. –  mmcglynn Sep 9 '09 at 17:23
    
That did it. Burned and ISO on the Mac using Disk Utility and was able to install. –  mmcglynn Sep 9 '09 at 18:03

Are you using a burnt ISO of Visual Studio 2008? It could be a bad burn, thus you could try re-burning it.

If it's a boxed copy, well, I guess it's possible that the DVD is simply bad. Given the fact that is it not mounting and causing trouble on multiple machines, I am tempted to blame the physical storage medium here.

share|improve this answer
    
No, This is VS 2008 Professional - Academic (I work in higher ed) –  mmcglynn Sep 9 '09 at 17:23
    
So it is a manufactured copy of VS 2008 then? Your probably going to have to contact Microsoft and inquire about obtaining a replacement. –  Matthew Ruston Sep 9 '09 at 17:50
    
I am burning and ISO on my Mac, will try that. –  mmcglynn Sep 9 '09 at 17:51
    
I agree that if it doesn't work on multiple computers, it could be a scratched DVD. Even if it does work on some computers, some drives have better capabilities at reading damaged media. I have an external drive that can read slightly-scratched media while my internal DVD drive cannot. –  Will Eddins Sep 9 '09 at 17:52
    
DVD is not scratched, looks perfect. –  mmcglynn Sep 24 '09 at 22:47

If this happens on multiple machines, you may have a dying or damaged DVD. Has it worked on any machine lately?

share|improve this answer

I'm having exactly the same problem, but can add some info.

1) I downloaded the ISO image of VS2008 Pro to start and burned the CD. This CD causes the described problem on my system but not on three others in my office.

2) I have a shrink wrapped copy of VS2880 Standard that causes exactly the same problem... but again only on my laptop.

3) I tried using an external DVD drive on my laptop but it made no difference.

4) I disabled autoplay via instructions I found on MSDN, thinking that it might be happening once the installer started to run, but it didn't help. I verified autoplay was disabled by using another CD with an auto-run installer and making sure it didn't start, but the VS2008 DVD still won't mount.

5) If I start my computer or windows explorer, I get the frame but it never populates. I can kill it with task manager and even choose "shut down" but ultimately I just have to hold down the power switch.

share|improve this answer
    
I feel your pain! –  mmcglynn Sep 24 '09 at 22:47

I googled around and got lucky... the problem, at least in my case, was a conflict between drive letter access of the DVD drive and the DVD itself. I can't imagine the details, but uninstalling Sonic DLA fixed the problem for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.