Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Two days ago I saw that MS Security essentials was prompting for a reboot on my wife's laptop in order to finish a clean-up. I have no idea how long MSSE had been waiting for a reboot, and like an idiot I only half paid attention to what it was asking, closed all the open apps, hit the big orange reboot button and let it do it's thing. When it rebooted and came up to the user selection screen for Vista, I noticed the red shutdown button in the lower right corner was indicating that updates could be installed if I shut down the laptop. So I figured I'd get everything out of the way, clicked the ShutDown and Install Updates option and again, let it do it's thing. It eventually finished installing the updates and shut down. I came by later and fired it up and left it on the user selection screen. My wife then selected a user, tried to log in, and found that she couldn't type in the password. No matter what key on the keyboard she hit, it did not register in Vista.

So I rebooted and tried to go into Setup mode to see if it was a Windows issue or a hardware issue. I can boot into the Setup/Diagnostics so I knew at least F2 and F12 worked. Once in the Setup software I found the Arrow Keys and the Enter key worked, and then I tried to set an Admin PW and saw that I could type any character correctly. So, the keyboard works correctly, just not in Windows.

No, I don't know what updates were being installed, but there were three of them. And no, I also don't know what MSSE had thought it had cleaned or why it needed a reboot. I was trying to do this in passing and got hosed in the process.

I also tried pulling the battery, unhooking the USB webcam and USB mouse (the only two peripherals attached to the laptop), pulling the power cable, and then holding down the power button for 30 and then 60 seconds as I saw after some Googling that this might help. No luck.

Any thoughts? I can't get in to look at Device Manager because both users setup on that machine have PWs that I can't enter. A USB keyboard is not being recognized. So I'm stuck.

The device is a Dell Inspiron 1720.

share|improve this question
    
At bootup, try hitting F8 to get to the windows boot option menu. Pick "Safe boot". If that lets you with an enabled keyboard, you can either debug the problem or try using the automatic restore (Windows should have created a restore point before the system modificaiton.) –  jdh Feb 2 '12 at 17:25
    
Have you tried plugging in a USB keyboard? I also found this suggested solution. –  Oliver Salzburg Feb 2 '12 at 17:32
    
Sorry, should have mentioned that I tried Safe Mode as well, and no luck with the keyboard, it was still just as dead as it was booting normally into Windows. I also tried a USB keyboard with no luck, but your linked article sounds like it's worth a shot. Now to find my Dell disks... –  Scott Feb 2 '12 at 18:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.