Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have this strange problem that has been plaguing me for almost a month. We have a small office (less than 20 users) that use Charter as an ISP - cable modem. We also have an external host, discountasp.net where we host our website and email. Once or twice a day we lose our ability to send email. We can receive email and browse the web but we cannot send mail. We get the following message:

Task 'usermail@ourcompany.com - Sending' reported error (0x800CCC0F) : 
'The connection to the server was interrupted. If this problem continues, contact your server
administrator or Internet service provider (ISP).'

(Usermail and ourcompany aren't the real names for privacy)

This problem will persist for about an hour and then it resolves itself and the sending problem goes away. Also, while the problem is occuring, I can connect to my Android phone hotspot and send and receive email just fine. In other words, when I use an ISP other than Charter, it works! Also, in a similar fashion, when at home on my ISP (not charter) email sending works fine. However if I connect to the VPN while the office is experiencing this sending problem, I also cannot send. Disconnect from the VPN (charter) and back to my home ISP (not charter) and sending works again.

You might say, viola, it's the ISP Charter. However, when I contact Charter they state there is nothing wrong on their side. When I contact Discountasp.net they have me perform a tracert to the smtp server which works fine, no drops. And they have me telnet to the smtp server which also works fine. So they then state there's nothing wrong on their side.

Anyway, I'm at a loss. I'm at the point of switching ISP's from Charter to anyone else in order to solve this problem.

Just thought I'd put this problem out there to see if anyone has actually fixed the issue and can save me the headache of switching ISP's.

BTW - it has nothing to do with the outgoing port being 25 or 587, either setting produces the same error.

Also, during the problem i've tried restarting our one domain controller, our modem and our WIFI router thinking it could be an internal issue - didn't help.

SOME MORE INFO--- Having the problem occur again today I decided to try sending from a different account and it worked. So the problem is narrowing down. The problem occurs when trying to send email using discountasp.net's smtp server. If I switch accounts, using different SMTP server, then I can send. So the problem only occurs when using discountasp.net's smtp server. Howerver, if I switch ISP from Charter to my phone hot spot then I can send just fine using discountasp.net's SMTP server. A real mind boggle.

share|improve this question

migrated from stackoverflow.com Feb 2 '12 at 18:26

This question came from our site for professional and enthusiast programmers.

    
probably an issue with spam protection on your smtp server or ISP provider –  Melvin Protacio Feb 1 '12 at 23:46

2 Answers 2

I agree DaBaer. Your problem is most probably caused by ISP Charter blocking external smtp server. It's strange that it works OK for most of the time, but your description sounds like this blocking issue. You might want to check some options:

  • Maybe you can register your discountasp.net email accounts on Charter user panel (some ISP's got this option), so that you will be allowed to use your email addresses from discountasp.net with Charter smtp server. But most probably it will be visible for your recipients in "from" part of email.
  • You might be interested in some independent smtp server providers. Just search google for them - most of theme got a free trial accounts to experiment. The advantage of this solution is that you are totally independent from ISP's, hot spots, etc. You are able to use the same settings anywhere from your laptop or other mobile devise. This is especially recommended for business uses.
  • There are some software solutions that allow you to use your computer as an smtp server. You will easily find them on google and some of them are free. Just search "free smtp" or "free smtp server". Good luck!
share|improve this answer

If your outbound SMTP is set to your actual mail server, you will most like run into issues with Charter, because most of those ISPs stop you from using outside SMTP servers and require you to send mail through them. I am not sure if this is the case, because you say it sometimes works. Try finding out what the recommended SMTP address is for using your ISP, and plug that in.

This was implemented by many ISPs a while back, because they wanted to stop spammers from using their server.

share|improve this answer
    
It's really unfortunate that some ISPs also block the 587 "Submission" port. The standard requires for it to disallow unauthenticated usage, after all, which already makes it much harder to abuse. –  grawity Feb 2 '12 at 20:22
    
It only happens once or twice day and only last for about an hour. –  Damon Feb 14 '12 at 17:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.