Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm currently troubleshooting a friend's USB-stick. But I can't seem to find the problem. I'm doing this over a chat, so I have no physical access to the device.

The device is a TakeMS USB2.0 stick. It shows no other numbers or names, and we couldn't find the stick on their website. The stick does not show up in compmgmt.msc, nor do we get a message when plugging the stick in. We can't tell if the device is actually completely broken. There's no light that shows drive activity.

Other PC's don't recognize the USB-stick. It has been tried on both W7 and WXP.

The person think it might be because of moisture that has gotten into the device. Will drying be enough to recover it? If moisture isn't the problem, what else can I try? File recovery programs?

EDIT: We tried TestDisk and PhotoRec. The disk doesn't show up there either.

EDIT2: We've found a way to recover the files. What the person needed had been printed out before and could possibly be scanned via OCR software. Though, I'd still like to fix the stick.

share|improve this question
I think the best way to "fix" the stick is to drop it in the trash (smashing first if sensitive data) and buy another. But look carefully in the end of the connector to see if one of the four copper contacts has been bent back. If so you might be able to cut open the connector body, flatten the contact back into place, and get it to work long enough to recover the data. – Daniel R Hicks Feb 2 '12 at 20:23
up vote 4 down vote accepted

Moisture, water, millk, heck even coffee can be catastrophic to USB devices, be they flash drives, or just the connectors to plug things into the PC.

In your situation, if you are plugging it in, and the computer doesn't even see it, chances are the connectors or the board inside of the device are corroded, thus causing your issue.

Some Things to Check:

  • Passive Hub: If you are plugging this into a passive hub, and having this issue, the hub may not have enough transient power left to power the device; try plugging it directly into the machine.

  • Front of Computer: Try plugging it into the back of the computer instead, given the risers/connectors for the front USB panel may not be plugged in properly on the motherboard (unlikely, but you would be surprised how many times I've found this to be true)

  • Different Stick: Make sure the PC is willing to even see the USB stick; try a known good one, and if it works, safely remove it, and then plug your suspect stick in. If the PC still refuses to see the stick, even though it saw the known good one, chances are, it's a bad stick.

  • Different PC: Try the stick in a different computer, or when running Linux, and check that the OS sees it. If it doesn't, or you don't have anything under /mnt for it, then the stick is most likely bad.

Those are the most common troubleshooting steps for this type of issue. If you have any questions, please do not hesitate to post back.

share|improve this answer
Thanks for the answer :) I completely forgot to mention that the stick isn't recognized on other PC's either. The person is also using W7. (Will update my question) – Simon Verbeke Feb 2 '12 at 20:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .