Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is what my Visual Studio 2010 window looks like. Obviously not ideal.

enter image description here

I used to have C# 2010 Express installed, all was fine, something happened, and then the colors went like this. I uninstalled everything, and installed a new copy of VS2010 Premium. The colors are still crazy.

I imported the .vssettings file from my work pc, but this only seems to have affected the editor window.

Any ideas how to get back to the default colors? (Resetting the settings via Import and Export Settings doesn't work, it just affects the editor window and the various things on the sides like Solution Explorer)

share|improve this question
    
Have you checked for a virus? –  Xavierjazz Feb 2 '12 at 22:33
    
@Xavierjazz I just use the Microsoft Security Essentials, and that's all up-to-date and not reporting anything. No other programs are like this, just Visual Studio. Seems a bit too specific for a virus, but I guess it's a possibility... –  Graham Clark Feb 2 '12 at 22:35
    
Attach the VS debugger to itself, and look in the Modules window for anything not by Microsoft. –  SLaks Feb 2 '12 at 22:44
3  
Given that VS2010 is a WPF application, that might be something to look into. It might not be specific to VS2010. –  Oliver Salzburg Feb 2 '12 at 22:46
1  
@GrahamClark I guess that rules out a generic WPF issue then :( –  Oliver Salzburg Feb 2 '12 at 22:54

2 Answers 2

up vote 5 down vote accepted

Sorted now. Somehow I had a key in the Registry hive Computer\HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0 called UseDebugColorScheme. Deleted that, and the colors are back to normal.

share|improve this answer
    
Dang it, I was just getting ready to say that. Did you have the Visual Studio color changing extension at some point? –  Patrick S. Feb 2 '12 at 23:14
    
hmm, that sounds familiar. Maybe! –  Graham Clark Feb 2 '12 at 23:15
    
It has a known issue that causes the rainbow if you don't set the color scheme back to default before removing the extension. Setting it to Default removes the UseDebugColorTheme key and another one that escapes me. –  Patrick S. Feb 2 '12 at 23:18
    
Please remember to mark your own answer as the solution to your question. –  Oliver Salzburg Feb 3 '12 at 10:27
1  
@OliverSalzburg yep, no worries, but I'm not able to do that until tomorrow. –  Graham Clark Feb 3 '12 at 16:19

This link possibly speaks to your issue. At least it sounds like it. Changing Visual Studio’s Color Palette The link says that if you had installed the “visual studio color theme editor”

Users who installed this extension for Beta 2 and customized the theme for VS2010 Beta 2 : If you have installed VS2010 RC on the same computer, you may experience a "rainbow colored" VS.

It may actually be the cause for some users of what was seen by the OP

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.