Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I click an e-mail address in Adobe Reader X, an Outlook e-mail window opens, even though Thunderbird is my standard e-mail client and assigned to the mailto: protocol.

How can I make Adobe Reader X open e-mail links in Thunderbird?

I'm using Windows 7. How to Change the Email Client in Adobe Reader doesn't seem to apply to this version of Adobe Reader, I don't see the drop-down menu of step 6.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Had the same problem, for some reason there were two different settings, which were called depending on the current user context:

  1. start regedit,
  2. find your way to

    HKEY_CLASSES_ROOT\mailto\shell\open\command

  3. check if it's the same value as in

    HKEY_CURRENT_USER\Software\Classes\Thunderbird.Url.mailto\shell\open\command

  4. check if it's the same value as in HKEY_LOCAL_MACHINE\SOFTWARE\Classes\mailto\shell\open\command

Please note:

  • Presumably the value should be something like "C:\Program Files (x86)\Mozilla Thunderbird\thunderbird.exe" -osint -compose "%1"
  • HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Associations\UrlAssociations\‌​‌​mailto\UserChoice should be something like Progid Thunderbird.Url.mailto
share|improve this answer
    
Thanks so much for digging through the registry, this had really been bugging me for a while :) –  doncherry Mar 9 '12 at 0:55
    
After updating to Adobe Reader 11, I seem to have the same issue, even though all the registry entries you mention have the correct values. Any ideas? –  doncherry Dec 21 '12 at 22:16
    
The first answer worked with Adobe Reader XI ver. 11.0.06. I suggest copying the Thunderbird value the first time you find it to avoid backtracking. I had to change the value in the third LOCAL MACHINE string. –  user301515 Feb 19 '14 at 17:14

I did all of the above but it did not work, but I found another solution.

  1. Go to Control Panel ⇨ All Control Panel Items ⇨ Default Programs
  2. Select Set Program Access and Computer Defaults (not Set Your Default Programs)
  3. Choose Custom
  4. Set Email program (not current program) to be Thunderbird

Step two was the tricky part.

share|improve this answer
    
Thanks! Sounds interesting and plausible, but I can't test it, since the accepted answer had already solved my problem. It'll certainly be helpful for other users. –  doncherry Nov 25 '12 at 19:07

You must be using Windows if you are getting as far as not seeing the dropdown. Adobe Reader (both 9 and 10) respects the Windows system settings for default clients.

When you go to Edit / Preferences / Internet / Internet Settings it is just opening the Windows internet settings dialog. Reader does not have one of its own.

The linked article is referring to Windows XP, where the Programs tab shows the dropdowns for each application type. Under Windows 7 this moved to the Set Programs button at the bottom of the tab in the Internet Programs section.

This will take you to the Default Programs settings page. Click Set Your Default Programs. In the list, choose Thunderbird, then click Set this program as default. This will make sure Thunderbird is selected for email in all cases where an email client can be invoked, not just when a mailto: link is clicked.

share|improve this answer
    
I'm using Windows 7. Unfortunately, this setting had already been set, i.e. Thunderbird had already had all the standards. I ensured it was set and tried again, but the compose window opened in Outlook again. –  doncherry Feb 3 '12 at 8:55
    
Does it do the same if you do Send To Email in something like Word? –  Paul Feb 3 '12 at 8:56
    
No, in Word or Firefox, a Thunderbird compose window opens. Adobe Reader is the only program in which I've encountered this behavior. –  doncherry Feb 3 '12 at 8:58
    
Why are adobe products so stupid when it comes to things like this. It seems to be ignoring the system setting, is this your machine or a work machine with a standard build? –  Paul Feb 3 '12 at 9:01
    
It's my personal, own laptop. –  doncherry Feb 3 '12 at 9:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.