Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have non-root access to a SUSE enterprise linux system. I need to use FUSE but the FUSE libraries are not installed on it (fuse itself is installed on it though). Hence I am attempting to install fuse in my home dir.

I have specified a prefix dir on my configure command , but make install fails due to the following reason:

libtool: install: /usr/bin/install -c fusermount /home/gabriel/opt/fuse-2.8.7/installation/bin/fusermount
libtool: install: /usr/bin/install -c ulockmgr_server /home/gabriel/opt/fuse-2.8.7/installation/bin/ulockmgr_server
/bin/mkdir -p /sbin
/usr/bin/install -c ./mount.fuse /sbin/mount.fuse
/usr/bin/install: cannot remove '/sbin/mount.fuse': Permission denied
make[2]: *** [install-exec-local] Error 1

As you can see, it tries to install mount.fuse to /sbin for some reason. I even tried by manually changing the path of the variable MOUNT_FUSE_PATH in the Makefile (it was set to /sbin), but the error persists. Is it because FUSE has to be installed as root?

I have tried this on fuse versions 2.7.2, 2.8.7.

share|improve this question
up vote 1 down vote accepted

FUSE is the bridge between the kernel and the user-mode file system. For the kernel, each FUSE instance is a regular file system. For the user-mode file system, it's just a user-level C-style interface with callbacks. Obviously, to be recognized as a file system by the kernel, a kernel module has to be loaded. So, even if you manage to install as user, without root rights you are still stuck. Sorry.

share|improve this answer

Check if you have the necessary rights and ask the owner of the fuse ctl directory:

ls -ld /sys/fs/fuse/connections
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .