Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having a very curious problem with Skype audio that has me stumped. Here's the setup:

  • I am on my desktop system, which is Intel Core i7, Win7x64, lots of memory and disk.
  • I use a Bluetooth headset along with an IOGear Bluetooth USB dongle

In all usage scenarios except Skype, two-way audio via the BT headset works flawlessly. In Skype, however:

  • Audio out works while "testing" sounds (in the Options/Sounds panel)
  • Audio out does NOT work when placing a call
  • Audio out does NOT work while displaying the Options/AudioSettings panel.

The strangest part of this is that it was working this morning. Nothing has changed, and now it's not working in a call or on the AudioSetting panel 100% of the time. When I switch to AudioSettings, or when initiating a call, I hear a slight crackling in the headset speakers, which sounds the same as when the audio output routing is being changed.

I have already tried:

  • Shutting down and restarting Skype
  • Multiple system reboots
  • Uninstalling and reinstalling Skype
  • Deleting and re-pairing the headset device

I suspect either Skype or Windows is getting confused when Skype grabs "exclusive" use of the audio out channel, which it does not seem to do when just testing sounds. I've tried disabling the Windows option "Allow applications to take exclusive control of this device" (in the control panel Sound applet, Speaker Properties) but this has no effect.

Can anybody suggest anything else to try?

share|improve this question
add comment

2 Answers

By bluetooth... which profiles are you implying "works" and "doesn't work". Typically, if you're using "A2DP" for your audio output, your microphone won't work. A2DP requires a significant amount of bandwidth that will not allow for a "Hands Free" profile while transmitting audio. Most headsets (that I've used) require you to switch to a "hands free" profile that sounds like garbage (mono, low-quality, etc...) but will allow you to use the microphone. Sometimes, that "switch" must be done manually... by disabling the a2dp profile and enabling the hands-free profile. Windows sees the "output device" for a2dp and hands free separately... so if you have a program playing music... and you switch to hands free... the music will keep playing on the a2dp interface (going nowhere essentially) and your hands-free output device is the only thing that will work.

share|improve this answer
    
I have to admit to being a neophyte when it comes to BT. Where would I look up in Win7 which profile is being used, and how to enable/disable a profile? –  Ex Umbris Feb 3 '12 at 18:57
    
Also, you say "your hands-free output device is the only thing that will work" -- that's my problem, it DOESN'T work. –  Ex Umbris Feb 3 '12 at 19:00
add comment
up vote 0 down vote accepted

I finally resolved this problem by completely removing and reinstalling the Broadcom device drivers and management software for the dongle. Following this and a reboot it still did not work, but after unplugging and re-plugging the dongle, everything was back to normal.

It may be that all that was need was the last step. On a system with builtin BT, this is probably equivalent to physically powering off the entire system (not just a reboot).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.