Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm getting this message, when I plugin a new USB device such as 3G modem or a mouse (into any port).

The error message USB Device Not Recognized

When I reboot leaving it in the same port, all works OK.

If I unplug it and plug it in again, I'm getting the same message again, the device doesn't work and Windows hangs when I try to reboot or shutdown.
I have a freshly installed Windows 7 (the same edition) on a secondary disk, and there is no such problem there.

Any ideas, how to solve this problem without a complete reinstall of the system?

share|improve this question
Anything with: -> computer ->right click ->open with or browse files – mic84 Feb 4 '12 at 6:32
check out the first thing I wrote there… the other system is probably "cleaner" . before you re-install, try doing a really good cleanup first. – Psycogeek Feb 4 '12 at 6:35
What is the actual, exact error message? Could you provide a screenshot? – Oliver Salzburg Feb 9 '12 at 18:31
@OliverSalzburg it is a generic message that Windows gives about a USB device “malfunctioning”. (XP, 7) – Synetech Feb 13 '12 at 19:56
@Synetech Thanks for that. I'll put that into the question. – Oliver Salzburg Feb 13 '12 at 21:30
up vote 9 down vote accepted

I solved a similar problem. My USB system had become very ill: although existing drivers would work fine, as soon as I moved any USB device to another port or installed a new device or tried, horror, to reinstall a device, Windows would refuse with "USB device not recognized". Within a couple of hours, my system was reachable by Remote Desktop only -- no USB at all worked.

The solution in my case was:

In that previous version of the log, I looked for the string "usb.inf". This allowed me to figure out that it was originally copied into C:\Windows\inf from:


This is of course system dependent. I copied both usb.inf and usb.pnf from there to C:\Windows\inf.

That's all it took in my case.

share|improve this answer
OMG! Thank you! This was driving me nuts. My brand new Logitech M310 mouse didn't want to install... I was getting "device driver software was not successfully installed" and then "USB Receiver: No driver found". I found the most recent usb.inf from C:\Windows\System32\DriverStore\FileRepository and then copied it in C:\Windows\inf\. No reboot required. I removed the Unknown Device driver and plugged it back and it worked! Thank you so much. – roychri Aug 26 '14 at 0:09
Exact same problem, preventing me from getting any android tablet properly installed with the ADB composite driver. Huge thanks! – aggieNick02 Feb 16 '15 at 22:50

These are the options listed at Microsoft for the issue of USB ports made non-responsive by removing or connecting USB devices:

1: Use Device Manager to scan for hardware changes

2: Restart the computer

3: Disable and re-enable the USB controller.

Since rebooting every time you want to connect or disconnect a USB device seems like a lame solution, I'd probably try reinstalling the USB controllers:

First, disconnect all USB devices, even your USB mouse. Then:

  1. Press "Ctrl + Esc" to open the Start Menu.
  2. Type Device Manager in the Search bar and press "Enter". Click Continue if necessary.
  3. In Device Manger, press Tab and use "Up" and "Down" to move the highlight to "Universal Serial Bus Controllers".
  4. Press "Right" and expand it.
  5. Press "Down" to move to the first item and press "Delete" to remove it.
  6. Repeat the step 5 and uninstall all items under "Universal Serial Bus Controllers".
  7. Reboot.
share|improve this answer
"Use Device Manager to scan for hardware changes" - it hangs forever – user626528 Feb 10 '12 at 6:23

I would first suggest to compare in Device Manager the USB driver on both versions of Windows 7, the "bad" and the "clean". If they are not the same, this can explain the difference.

Secondly, I would suggest booting the "bad" version in Safe mode. If the problem now disappears, then the cause is some installed product. Use Autoruns to turn off stuff in bunches and rebooting until you find the guilty product.


As you have said that Device Manager hangs forever, your computer really seems to be in a bad shape.

The only solution to avoid complete re-installation may be to refresh Windows by doing Startup Repair in Windows 7. This will only refresh Windows and leave alone all installed applications and their settings. You will need a Windows boot DVD of the same service-pack level as your installed system.

If your Windows installation is too messed-up so that Startup Repair fails, you will need to reinstall Windows from scratch, recommended with a reformat of the hard disk. So ensure you have backups of all your data, and installation media for all your products including serials. On some computers you receive a boot CD that allows you to restore the system to its state as when bought.

share|improve this answer

Did they used to work? If not, then perhaps you have a bad USB hub/controller. If they did, then unless there was a short-circuit or something to damage the hub/controller, it should be possible to fix it.

I have seen this with a few different kinds of devices. In most cases, there was nothing actually wrong with the device. (Which makes me feel really bad about spending $27CAD to ship my QX3 back to Intel in the USA in exchange for a check for $24CAD. >:-|)

There’s a few things to try before assuming the device is at fault. You said the problem is not device-specific, so the first two options are more likely to help unless you somehow have a bunch of bad USB devices.

  1. Ensure that the cables are all correctly connected. Sometimes the cables (including the ones that connect from the ports on the front or back of the case to the motherboard) can come loose a bit, thus disrupting the connection.

  2. Clean the pins. The metal pins on the USB connector (on both the device/cable and the port) can accumulate a patina (especially in humid conditions), which disrupts the signal. Use a cotton swab with water/soap/alcohol or something to clean them off, thus restoring their electrical connection. I usually just resort to lightly scrubbing them with a cardboard Emory board.

  3. Open a command-prompt (cmd.exe), type set devmgr_show_nonpresent_devices=1 followed by devmgmt.msc. In the Device Manager, select View->Show hidden devices. Now find the device that is giving you problems, right-click it and select Uninstall. Disconnect the device, reboot, and connect it when Windows has completely loaded.

  4. Run Windows Update to see if it can detect the device and/or if there is a newer driver available.

share|improve this answer

Some USB devices are not compatible with USB power management in some operating systems. There is tickmark in USB hub properties for that.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .