Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Microsoft Word 2010 (Professional) is not spell checking some paragraphs for some reason but I would like it to do so.

If I crtl a > under review tab, language, set proofing language dialogue box > the do not check spelling or grammar checkbox is 'squared out'. However if I clear this setting so its blank (neither a square nor a tick) it reverts to the squared out setting again, if I reopen the dialogue box. I've tried set as default and the language dictionary (UK eng) is installed)

I have checked the setting under the home tab > options > proofing and there's nothing wrong there as far as I'm aware (i.e. first four of the checkbox settings are ticked, under 'when correcting spelling and grammar in word')

If select don't do select all but only select a few paragraphs then the 'set proofing language dialogue box' retains my settings, and word spellchecks those few paragraphs correctly.

If its of any relevance, I'm using some different quick styles (headings and main body text) as its a fairly big document (~ 30 pages). I checked the stlye used for main body paragraphs and 'do not check spelling or grammar checkbox' is unchecked.

Is there something really obvious I'm missing here? I'd really appreciate some help - thanks!

share|improve this question
    
Press <kbd>F7</kbd> to force a check and see what happens. Also check the language of those paragraphs. They could be mistakenly marked as another language. –  billc.cn Feb 4 '12 at 12:40

3 Answers 3

I had this problem with a Word document sent to me by a student intern. The paper was riddled with obvious (to me) spelling and grammar errors. Not only was the "Do not Check Spelling and Grammar" box checked, but when I unchecked it, many paragraphs were still not being checked. I had to open the review pane and manually remove the "do not check" box therein multiple times. The problem then spread to my new documents! It required going back into options, unchecking the "do not check..." box and checking "set as default" to fix my own documents.

share|improve this answer

Check what language is being used for a paragraph.

Review → Language

This was the cause of my problem where auto-correct was not working.

I've never understood why sections of my docs keep appearing in different languages. It's not something I ever change.

In Office 2000 I could see the language in the status bar where I would look automatically whenever strange things started to happen. Unfortunately, even though I have ticked Language when I right-click on the status bar, it doesn't display the language.

It wasn't obvious to me that Language would be in the Review section and it is tedious to have to use Review > Language.

share|improve this answer

I had the same issue but found out that I had to uncheck the option "Ignore words in UPPERCASE". You can set this option under "Language Preferences" and then "Proofing".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.