Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a multi computer pseduo ad-hoc home network using Windows 7 Homegroup and some Remote Desktop on occasion. This has worked well to date until I added a new machine and now I am having trouble with the new machine and reading from it locally.

Original Setup:
Router: D-Link DIR-655
Laptop #1 - Wired Windows 7 Pro x64 Laptop used primarily for work
Laptop #2 - Wireless Windows 7 Pro x64 Laptop used primary for home/personal 
Laptop #3 - Wireless Windows 7 Ultimate x64 Laptop used for email/web by my wife

The most common uses were streaming media via Windows Homegroup from Laptop #2 to Laptop #1. This has worked flawlessly so far. I also used Remote Desktop to remote into Laptop #1 from Laptop #2 when I was in with the family and needed quick access to my work machine, or do some work while my wife watched one of the TV shows that I hate.

New Addition:

Desktop #1 as HTPC/Media Server: Wired Windows 7 Ultimate x64.  Brand new 
    custom built PC that eventually (when Hard drive prices come down) will 
    have 4-6 TB of media storage and will stream to other PC's in the house, 
    and possibly an XBox in the future.  Right now it just has a couple of 
    old smaller drives to serve in the interim.

The problem: All original computer are still working as well as before, but whenever I attempt to read from the HTPC, I get extremely slow speeds. I can write to it just fine, but read performance is poor. I did a speed test using a freeware tool I found and the write speed from Laptop #1 to Desktop #1 is 680Mbps, but the read speed for the same link is less than 140 kbps.

Network troubleshooting is probably among my weakest skills. The drivers are all current in the new machine, so I'm not sure where to turn next. I was hoping someone might have an idea that can point me in the right direction.


One thing I neglected to highlight is the WAN performance, both reading and writing to/from Desktop #1 is as good as the other machines. The issue appears to be limited to LAN.


No idea what I did, but I moved the system back to my office to run some tests and to boot into Linux. Everything seemed ok, so I booted back into Windows and reran my speed test. Everything came up great. So now I think it is the network cable. I hook it back up where it was and now it seems to be working better. I'm guessing either a bad connection, or Windows saw the LINUX CD coming and decided to get it's act together.

share|improve this question

The first step, in my opinion, is to check if it's the Windows stack, or the hardware. You said you have the newest drivers, so that's good. Do you have a Linux live CD/DVD handy (Ubuntu etc)? If so, try booting into that and check network speed.

If network speed is still slow, then you know it's hardware. You could flash the BIOS, but most likely it's just a bad network card.

If network speed is fine, then you know it's something in Windows. You said your drives are "old smaller drives". Are you sure the drives themselves are OK?

If it is Windows, and if your hard drives are OK, you could uninstall the NIC and reboot and let it reinstall. You could look at system logs to see if there are errors. Right click Computer, click Manage, go to Event Viewer -> Windows Logs. The System log would be the most helpful.

share|improve this answer
I am virtually certain the drives are good, but a good hard drive can go bad. The main storage drive in the problem computer is actually a larger drive from another machine that was working in this network (used to be the main drive of Laptop #2, but I didn't need the extra capacity in that computer anymore). I'll check on your other suggestions. I have a flash drive with Linux Live on it somewhere, so I'll give that a try. – psubsee2003 Feb 5 '12 at 2:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .