Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was able to setup an FTP site that I was able to access via ftp://127.0.0.1/ or my local(static) ip. To do this I followed these instructions (with the exception that I did not bind to 127.0.0.1 as suggested) http://learn.iis.net/page.aspx/301/creating-a-new-ftp-site-in-iis-7/ I have created a firewall exception for port 20 and 21, and setup port-forwarding on my wireless router. But I can only access the site via local-host, and I need to have a friend have read access to it.

So how do I enable remote access to it? (I'd rather not purchase a domain-name)

My setup: IIS 7.5 Windows 7 Professional Wireless Network Norton Internet Security 2012 An Internal Static IP Address

share|improve this question

3 Answers 3

When you bound the FTP service to your 'local static IP' -- is this a public IP address? Some ISPs dole out static IPs which are private IP addresses which then are 1:1 NAT'd to a public IP address. If your static IP address is in the following ranges:

10.0.0.0 - 10.255.255.255
172.16.0.0 - 172.31.255.255
192.168.0.0 - 192.168.255.255

then it is a private IP address and not externally accessible. You will need to find out what your public facing IP address is and have your friend attempt to connect to that. Also, it is possible that your ISP is blocking traffic on port 21.

share|improve this answer
    
I've tried connecting to it within the local network from a diff. computer, and that hasn't worked. (And I've tried both local and external IP's) I bound to a wildcard IP, not my static internal IP. I'm on Comcast. I read something about ISP's blocking, but I didn't see which IP's do block the common FTP ports –  Usta Feb 5 '12 at 5:09
    
Even if you ISP is blocking, you should still be able to connect to your FTP via the LAN. I suspect that you have a Windows Firewall issue. Why don't you temporarily disable windows Firewall on the FTP server and attempt to connect to the site via another PC on your LAN. If you are running Windows 7, make sure that Windows Firewall is configured appropiate 'place' -- it has seperate options for Domain Networks, Home or Work (private) networks and Public Networks. –  Art Feb 5 '12 at 16:44
    
I have my network-location set to home, I have Norton rather than Windows Firewall as my Firewall, but I went ahead and added exceptions to both of them (For ports 20 & 21) Do I need to specify a program or just a port? And if a program, would program would I define? IIS Manager? –  Usta Feb 5 '12 at 20:20
    
I would temporarily disable both of them and then test a LAN connection to the FTP server -- that would rule out the firewall as the source of the problem if you still cannot connect. –  Art Feb 5 '12 at 20:50
    
I tried disabling both, and it didn't work. When I hover my mouse over my computer in the IIS Connections pane, it says "localhost"; Is that normal? or do I have IIS setup wrong (I used default settings) –  Usta Feb 5 '12 at 21:11

FTP is a special protocol that requires either the client or the server to open ports other than 20 and 21. Most of the time the server has to do it, which is normally called "passive mode" in the client.

You have to setup either the built-in FTP rule or use port triggering. The former requires the router to parse FTP traffic and automatically forward the port specified in it. The latter method is really a work around. You'll have to find out what port range your FTP server program uses for passive connections and set the router to forward all of them when port 21 (tigger port) is connected.

share|improve this answer
    
I've setup my Wireless Router to port-forward, but if that were the issue, wouldn't other computers on the local network be able to see it (Port-forwarding would only be necessarily for external clients) I've configured Norton to open ports 20 and 21, but only inbound. –  Usta Feb 5 '12 at 5:18
    
The FTP server uses OTHER random inbound ports as well and a special rule (designed for FTP) must be used to handle it. Allowing inbound traffic to 20 and 21 won't help you unless your clients can all do active connections. Read the thrid paragraph here. –  billc.cn Feb 5 '12 at 5:23
    
So how would I correctly setup a passive connection and make the necessary firewall exceptions? –  Usta Feb 5 '12 at 6:31

It sounds like the Windows Firewall may be blocking the connections. Go into the firewall and change the settings to allow incoming ftp messages by choosing "Allow a program or feature through Windows Firewall". If you are using Norton or other security suite with its own firewall you will have to do the equivalent in that program.

share|improve this answer
1  
A more detailed answer including screenshots or step-by-step tutorials would serve the OP a lot more. –  user 99572 is fine Mar 9 '13 at 21:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.