Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a pretty long list of time-wasting sites in the hosts file and it is working just fine, however I'm experiencing a very strange behavior - every day or two (my PC turns on automatically every day) from the file disappear two lines:

127.0.0.1 youtube.com
127.0.0.1 www.youtube.com

Even the line-breaking symbols stay there. I am using the latest stable Chrome and two Youtube-related extensions - FancyTube and YouTube Ratings Preview. I don't remove them because sometimes I need to visit YouTube and I don't want to deal with advertisement or rickrolls. The interesting part is that I tried to make the file read-only and to remove write-rights from everything except me, but it didn't help (flags haven't been reset). Is it one of the extensions or something else? Or maybe Flash?

share|improve this question
    
YouTube has become self-aware. –  iglvzx Feb 5 '12 at 7:29

2 Answers 2

Do you have Microsoft Security Essentials? Sometimes it detects a threat and changes file back to default.

share|improve this answer
    
Yes, but only the YouTube entries‽ o.O –  Synetech Feb 5 '12 at 7:23
    
No, I don't have any anti-virus products installed, and my file isn't being changed to default, just two lines, with youtube in them. –  Olegs Jeremejevs Feb 5 '12 at 7:25

Try giving write permissions to "administrators" only, rather than yourself, and turn on UAC. As long as you run programs as a regular user, they should not have access to the file.

If a program asks for elevated permissions, check the file before accepting - it might give you a clue.

share|improve this answer
    
Okay, I'll try this later today. –  Olegs Jeremejevs Feb 5 '12 at 8:24
    
Sorry for the... um.. delay. Recently gave it a try, no success. Over some time I've noticed, that Youtube isn't the only one, who disappears. A week before I've switched to the StayFocusd extension. It takes a bit less time to simply disable it than to find the hosts file and remove a line, but I've done that just once, the productivity seems to be fine. –  Olegs Jeremejevs Mar 23 '12 at 15:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.