Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I changed the associated application for playing .MP3 files from VLC Player to GOM Player within Windows. Double-clicking a .MP3 file causes GOM Player to launch (as expected), but the icon still shows as VLC (the traffic cone), rather than the GOM Player logo - which is confusing. Is there any way to get the correct logo, so it shows for the associated player (GOM)?

I've tried refreshing the folder, restarting, and putting the associated application back to VLC, then GOM again to try to resolve, but it has not made any difference.

Using XP Home SP 3, with the latest release versions of GOM/VLC players.

share|improve this question
add comment

4 Answers

To modify an existing file type

  1. Open Folder Options in Control Panel.

    • Click Start, and then click Control Panel.

    • Click Appearance and Themes, and then click Folder Options.

  2. On the File Types tab, click the file type you want to change, and then click Advanced.

  3. If necessary, modify the file type description, and click Change Icon to change the file type icon.

This answer is from the Windows XP Professional Product Documentation.

share|improve this answer
    
When I go into Folder Options in Control Panel, the GOM Logo appears next to the MP3 extension, but I see the VLC logo icon when viewing MP3 files in Windows Explorer. –  Goto10 Feb 5 '12 at 17:50
1  
I'm not sure why... try restarting your computer. –  wizlog Feb 5 '12 at 18:15
    
They said they already tried restarting. –  Synetech Feb 5 '12 at 21:29
    
Restarting after trying my answer... –  wizlog Feb 6 '12 at 22:34
add comment

You could try to change the icon with Default Programs Editor (similar questions answered here and here)

File Type Settings -> Icon -> (search for mp3 files) -> Browse to GOM player folder, and select that program, or elsewhere in the program directory where the icon file is.

Here's an example screenshot doing that same process for another file type: use Default Programs Editor to change a file icon in Windows XP

share|improve this answer
add comment
up vote 0 down vote accepted

I believe this behaviour is by design in XP. If I use Control Panel->Folder Options->File Types to change an extension, another application can be associated, but the icon for the association stays the same (even after a restart).

For example, in this video .TXT files are set to open with WordPad instead of Notepad, but the icon stays the same.

If I use the GOM Player to set up associations, I do successfully get the icon changes as well. Unfortunately, it does not give the option to associate itself with sound files, such as .MP3.

share|improve this answer
    
“By design” What does that even mean? Why would they purposely make it not work? It did not update because the icons are cached. You can fix it by clearing the cache. –  Synetech Feb 11 '12 at 4:19
    
> Unfortunately, it does not give the option to associate itself with sound files, such as .MP3. Feel free to request they add an option. –  Synetech Feb 11 '12 at 4:23
add comment

Rebuild your icon cache.

  1. Get TweakUI, install, and run it
  2. Click the Repair branch in the tree
  3. Select Rebuild Icons from the drop-down (it should be selected by default)
  4. Click Repair Now
  5. Reboot


Another (manual) method:

  1. Open %userprofile%\Local Settings\Application Data
  2. Delete IconCache.db
  3. Reboot
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.