Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with creating an index to a document: it was not created from me, and it had the headers of the chapters as normal text, without using styles. I applied styles (Header 1, 2, 3 and Body) to the whole document, hoping that it would allow to create the index automatically.

But when I insert the index, it appears empty.

I tried to create a dummy document to try the function and it works properly; so what could be wrong in the other document?

share|improve this question
    
Hi, did you use built in header styles or custom ones? If you use custom header styles, you have to set the index to also use custom styles and then define, which style is which index level. Look in the index settings, I cannot give you the exact dialog name. –  Juhele Feb 5 '12 at 17:35

1 Answer 1

up vote 3 down vote accepted

I've found the solution to my problem.

It was caused by the fact that in the settings of the style used as header, it was not set for appearing in the index. More in detail, I had to go in the "HeadingX" setting (for the styles I've used), and then in the "Outline&Numbering" tab; there, I had to choose in the "Outline level" drop-down menu, the level in which I want the index entry to appear.

I hope that this could help someone else.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.