Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to remove java 6 32 bit and install java 7 64 bit, but after initially having the uninstaller open and execute successfully, asking me to plan a full removal after a reboot, the uninstaller did not come back, and neither does executing it again work.

I've tried using revouninstaller to remove the old java, which seems to be successful, but java 7's installer still won't execute.

When I execute the offline installer, it asks for administrator privileges, loads up the MSI, and then vanishes. After consulting the event viewer I found these entries from MsiInstaller:

Product: Java(TM) 7 Update 2 (64-bit) -- Installation operation failed.

and

Windows Installer installed the product. Product Name: Java(TM) 7 Update 2 (64-bit). Product Version: 7.0.20. Product Language: 1033. Manufacturer: Oracle. Installation success or error status: 1602.

All I know is that error 1602 is supposed to mean user cancelled the installation, which leads me to believe either UAC isn't working correctly (seems to work fine though), or there is some registry entry blocking the MSI installer (though I've checked manually).

share|improve this question
1  
See if this Microsoft fixit utility helps..support.microsoft.com/mats/Program_Install_and_Uninstall –  Moab Feb 5 '12 at 20:23
    
I ran it and it says there were no problems found. Says it's not related to the registry. Installer still closes. Thank you for trying though! –  Alex Feb 6 '12 at 1:14
    
Try the Java online installer from the java site –  Moab Feb 6 '12 at 23:17
    
Didn't work either.. Probably just gonna disregard it, I was looking for an excuse to reinstall my PC anyway, so this is just another reason to do it. –  Alex Feb 7 '12 at 19:09
    
Still weird that there's no good way to solve this, it's really hard to clean out all the remaints java leaves behind it seems –  Alex Feb 7 '12 at 19:09
show 1 more comment

3 Answers

I had this same problem when I removed and tried to re-install JRE 7.

I deleted the key HKEY_CURRENT_USER\Software\JavaSoft\FIUCancel to allow re-install.

share|improve this answer
    
This did it for me! –  Marcus Ekwall Mar 5 '13 at 11:47
add comment
up vote 1 down vote accepted

Actually, on a second thought, instead of doing the reinstall, I just went on digging more in the registry. I just searched for 'java' and deleted all the entries that I deemed relevant to java runtime (so not the javascript, msjava, javavm, etc) entries, and it worked!

I got java runtime 7 installed now, works like a charm.

So if anyone else runs into this, might be worth trying to dig out the registry manually!

share|improve this answer
add comment

I had the same problem with a later update. The uninstall would close and "Product: Java(TM) 6 Update 33 -- Removal failed." and "Removal success or error status: 1602." would appear in the event log.

I ran the Microsoft Fixit utility at http://support.microsoft.com/mats/Program_Install_and_Uninstall (thanks Moab). That allowed me to select Java 6 for uninstallation and the uninstallation completed successfully.

I also used the Fixit utility to remove Java 7 Update 6 which had the same problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.