Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After I enter a new search engine and its URL, how can I actually add it to Chrome? There is no button to push; actually there are no control elements whatsoever.

share|improve this question
1  
I found out what was the problem. I was trying to add another search engine with the same name but different URL. – Erin Pakston Feb 9 '12 at 9:39
    
I had a similar problem as Erin. Chrome does not give any nice warning when you enter something in wrong (e.g. a mal-formed URL or repeating the same search engine name). It just fails to add the search engine silently. – Jess Riedel Jan 7 '14 at 19:11

How to add a search engine:

  1. Options > Basics > Search > Manage search engines...
    or chrome://settings/searchEngines
  2. Other search engines
  3. The first field is the name to give the search engine.
  4. The second field is the keyword, for use in the address bar.
  5. The third field is the URL, where %s is the variable for a query.

    add

or...

  1. Right click > Add as search engine...
    right click

  2. Enter the name, keyword, and URL.
    popup

How to use a search engine:

  1. Type the keyword in the address bar.
    keyword

  2. Press Tab or Space.
    search

  3. Enter a query.
    query

  4. Press Enter.
    result


More information:
Google Chrome Help - Manage search engine options
Google Chrome Help - How to search in Chrome

share|improve this answer
    
Note that the dialog box in step 2 does not exist in the current versions of Chrome. In particular, there's no nice "OK" button. – Jess Riedel Jan 7 '14 at 19:12

The other answer is out-of-date. In current Chrome, right-click the address bar, select "Edit search engines..." and scroll to the bottom of the lower list of search engines. You need to fill in the three boxes for name, keyword and URL. If any of these do not have valid text entered, they will be filled in with a grey background and there is no way to add the search engine. Once they are all white, you can press enter to add the new search engine.

There doesn't seem to be a way to add using the mouse, and the new search engine will just disappear into the big long list of search engines once added, so you need to go and find it to check it worked. You can then hover it and click the "Make default" button that appears to use it as a default search engine.

Try "Example", "example.com", "example.com/%s" to test this if you're not sure what kind of values to fill in.

share|improve this answer

Funnily enough, now the option to right click on a site's search box and add an SE (with popup and three text boxes) is gone and thats how I came to this page.

Apart from Simon's answer, (I cannot believe they would make things manual/worse for us users), also note that now do-no-evil-google also makes sure that when you add a site as search engine, it also auto-adds the site itself with site name as keyword and apparently there is no way to prevent this unneeded duplication.

So remember top clean up your SE regularly from this nonsense. Chrome has decided they will never fix this as non-power users dont know how to add an SE and this is for a good user experience !

To make things easier, add the path to settings with an easy keyword on an SE.

I have an SE with kywd "cse" (Chrome Search Engines) which leads to "chrome://settings/searchEngines"

share|improve this answer
    
This is really a comment and not an answer to the original question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – DavidPostill Dec 13 '15 at 20:27
    
Thanks for the suggestion. – killjoy Dec 14 '15 at 22:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .