Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had an install of ubuntu on an old hard drive in a computer with a nvidia graphics chipset in it. I just moved the drive to a new computer with an amd card, and I am having troubles switching over. I have to boot into shell mode, and then change the driver section of device in xorg.conf to vesa to get it to boot gnome in safe graphics mode. From there I can install the catalyst/fglrx driver, and then restart when it is finished to finalize the changes. When I reboot however, it fails to do anything, so I have to repeat the process. The contents of xorg.conf actually get reverted back to the nvidia settings after the driver install. How can I install the drivers and get it working? Contents of device section of xorg.conf:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 240"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 240"
    BusID          "PCI:2:0:0"
    Screen          1
EndSection
share|improve this question
    
I would recommend running amdcccle when you are able to boot into the graphics mode. – Karlson Feb 6 '12 at 3:26
    
Running from the safe mode with the drivers set to vesa? I will try it soon. – a sandwhich Feb 6 '12 at 3:48
up vote 1 down vote accepted

That makes no difference amdcccle is the native configuration tool for AMD/ATI cards it will create the configuration for you. As long as you have the fglrx and fglrx-amdcccle packages installed.

share|improve this answer
    
I got it working. I had to boot into safemode, then remove all graphics drivers, and then manually install amds. – a sandwhich Feb 6 '12 at 21:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .