Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm sorry for this newbie question, but I'M lost at this point:

I'm using Aquamacs 2.4 on MacOS X 10.6.8 and I'm currently trying to learn emacs and org-mode. I have several *.org files containing TODO items and I was able to display an agenda for those files,
however suddenly (I must have changed a configuration, but I don't see what I did wrong) the "standard agenda" (with command "a") is completely empty:

There is only one line "Week-agenda (W06):" nothing else.

However, all org-files are in the agenda file list and if I open one file and choose Set Restriction Lock to the current subtree, the rebuilt agenda view gets populated with the items from that subtree. But without the restriction I get an empty agenda again.

How can I switch back to the configuration I had before? Any ideas what I might have done wrong?

btw: when I invoke the agenda with option "t" (list of all todo entries) it seems to work and I really get this list.


EDIT

some more information: it seems to happen when I load my whole org-files directory as "agenda files". Something in there seems to change the agenda configuration. I'll try to add the files one by one and see when it happens.

share|improve this question
    
Do you happen to remember making any configuration changes (through customize or .emacs file) of late? (Since you mention you must have). – Jonathan Leech-Pepin Feb 6 '12 at 15:43
    
it seems, but I don't know what I changed (I did not do it purposeful). I deleted all preferences and configuration files and now it works again... :D – MostlyHarmless Feb 6 '12 at 16:20
    
@JonathanLeech-Pepin: it seems that the change of configuration is made by loading some file as an agenda file... I'll try them out. (see my edit in the question) – MostlyHarmless Feb 7 '12 at 9:26
up vote 1 down vote accepted

Actually C-c a a will not show todo tasks unless they are scheduled or have deadline associated with it. So what you seeing is standard thing. you can check this by adding a schedule to any task using C-c C-s and see them with C-c a a (agenda for current week)

share|improve this answer
    
I DID see tasks with DEADLINE or SCHEDULED dates in the agenda before, but then (after - I assume some magical shortkey) nothing was displayed any more in the "normal" agenda. It seemed to ignore everything. – MostlyHarmless Feb 6 '12 at 15:35
    
@Martin Are you sure you have scheduled/deadlined entries for the current week? It sounds silly but if that's what happened you would seem to have a blank agenda. – Jonathan Leech-Pepin Feb 6 '12 at 15:44
    
No, I don't have a blank agenda - I (still) have scheduled and deadline entries for today and the following days but with some strange configuration they seemed all to be hidden (maybe I've added a filter criterion for the agenda) Where are such changes of the configuration saved? – MostlyHarmless Feb 6 '12 at 16:21

Maybe you've removed your documents from the list of agenda files somehow? According to the official page you can add the document with C-c [ to the list of agenda files.

share|improve this answer

I experienced this exact problem randomly starting last week on Ubuntu 15.04 (vivid). My current emacs version is 24.4.1 (I use the Ubuntu package). I have a clocktable at the top of my todo.org, and I found that removing it temporarily fixed this problem for me.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .