Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've installed Blueman to use instead of the default KDE 4.3 bluetooth applet. I've added blueman-applet to KDE's startup, so that works, but when I enable bluetooth on my laptop the default applet (kbluetooth4) gets started as well.

How do I prevent this? Or better yet, how do I make it so that KDE starts blueman when I enable bluetooth, and I don't have to make it autostart?

share|improve this question
up vote 0 down vote accepted

just run: sudo apt-get remove kdebluetooth

share|improve this answer

You can write a program hooking into the HAL events. halevt, ivman and a bit of bash glue can go a long way. Basically every time the bluetooth device appears, launch Blueman, wait a few seconds and kill Kbluetooth4.

KDE has an interface for both managing devices and hardware stacks in System Settings on the Advanced tab. Have a look whether this is useful, I can't check for lack of Bluetooth.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .