Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I would like to use vsftpd with virtual users and I installed vsftpd and added two users (ramon and dragon) via htpasswd to my file /etc/vsftpd.passwd. The /etc/pam.d/vsftpd is configured to use this file.

auth  required item=user sense=deny file=/etc/ftpusers onerr=succeed
auth    required pwdfile /etc/vsftpd.passwd
account required

@include common-account
@include common-session

The user "ramon" is also available in /etc/passwd. A login to the ftp with the user "ramon" works as expected. But a login using "dragon" does not :/ The result is always

Login failed: 530 Login incorrect.

Since it's possible that I made a mistake I tried the exact way documented in /usr/share/doc/vsftpd/examples/VIRTUAL_USERS/README. Still no luck. I can login with the user "ramon", but not with the user "dragon".

Any ideas?

share|improve this question
is vsftp even active? or do you still have bsd-ftpd (or other) running – Tim Haegele Feb 6 '12 at 14:29
Hi Tim,vstfp is active, yes. I can see entries in /var/log/vsftpd.log as well. – Ramon Feb 7 '12 at 8:00
possible duplicate of VSFTP configuring virtual user using passwd – Ƭᴇcʜιᴇ007 Mar 7 '12 at 22:38

I had the same problem, but this thread helped.

Apparently vsftpd has problems with MD5 hashes. When I instructed htpasswd to use crypt() (the -d option), it suddenly worked:

sudo htpasswd -c -d -b /etc/ftpd.passwd twilight sparkle
share|improve this answer

Use below to configure.

I have tried this on my setup & it is working as expected.

share|improve this answer

Adding the -d option to htpasswd worked on my Rackspace / Ubuntu setup: htpasswd -c -d passwd username.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.