Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I rashly installed Ubuntu 11 on my 30GB recovery partition on my Windows 7 PC in an attempt to dual boot. Now, Ubuntu works perfectly, but my boot loader will not let me load Windows.

However, I can still access my Windows files through Ubuntu by mounting the 289GB partition that contains my Windows files.

Is is possible for me to recover Windows 7? As in be able to load Windows 7 after startup?

Thank you for aiding someone foolhardy enough to install Linux without a backup disk image.

share|improve this question
1  
The system probably originally was configured to boot to the recovery partition, which would then pass along the boot to the OS if the recovery partition had not been invoked. Getting the addresses in the boot manager should be all that is necessary to fix this. –  music2myear Feb 6 '12 at 14:54
    
Thank you, how do I do get the addresses, and what should I configure? –  David Faux Feb 7 '12 at 0:38
add comment

3 Answers

up vote 1 down vote accepted

David, I'm afraid the suggestion by Pl3ppp won't work for your situation since installing Ubuntu alters the master boot record. Your best bet is to use the Windows 7 disk in order to perform an OS recovery. If you need a Windows 7 disk you should be able to request one from the PC manufacturer. I believe you might be able to get it for free.

In the future instead of dual booting I'd suggest installing the alternate OS on a large thumb-drive (8GB or 16GB) or an external hard drive and then telling the BIOS to boot using the alternate device. It should eliminate some if not all of the headache you're experiencing now.

share|improve this answer
add comment

Have you booted from a Windows 7 disk and attempted a repair? That may be of some assistance. However, I would be sure to back up all data on teh 289GB partition that you can still access.

share|improve this answer
    
Thanks, I'll procure a Windows CD. –  David Faux Feb 7 '12 at 0:36
add comment

If you boot into your linux machine, and run Gparted you should be able to manually select your windows 7 partition as the first boot (right click the partition, Manage Flags, Set as 'Boot') Apply the changes and restart. That Should Sort this out for you

share|improve this answer
    
Thanks, I tried that, and Windows strangely still doesn't load with the Boot flag on the Windows partition. –  David Faux Feb 7 '12 at 0:37
    
You can add the win7 MBR to the hard drive with ms-sys. I don't know if that'll be enough to get it working for you. Did you try sudo update-grub from ubuntu? –  Rob Feb 7 '12 at 19:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.