Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently inherited a MacBook Pro from a colleague who has left the company. One of the annoying features that they had set up is that in every window/application that I can type the system will automatically try to enter closing quotes when ever I enter a single one.

I think the main problem is I don't know how it is supposed to work, as sometimes it adds it in, other times it does not. Either way, I hate it.

The way it appears is, as soon as you type the single character ', " or ~ (and probably multiple others) an underscore appears underneath it and I have to hit the space bar to accept the single version (did I mention it was annoying).

I've looked in the preferences and I can't see anything that could be causing this.

share|improve this question
Your first paragraph is broken. – Daniel Beck Feb 6 '12 at 14:42
Thanks, fixed the paragraph – Liam Feb 6 '12 at 14:52
You can also experience this feature on Windows by selecting the U.S. (International) keyboard layout. – Daniel Beck Feb 6 '12 at 14:59
up vote 3 down vote accepted

These are called deadkeys and used to enter diacritics to type ñ or é when followed by the proper letter (n or e in these cases). If you type a character that cannot be combined, it adds the character without combining it, as e.g. ~t.

Select a different keyboard layout in System Preferences » Language & Text » Input Sources, enable the Input menu and open the Keyboard Viewer to see which keys are set as deadkeys in your current keyboard layout (highlighted when you press the required modifier, e.g. Option):

enter image description here

Some keyboard layouts contain keys as both deadkey and regular character. The British keyboard layout for example has regular ~ next to left shift, and as deadkey on Option-N (shown in screenshot). The key next to left shift also has ` both as deadkey (when pressing Option, shown) and regular character without modifiers.

You can use Ukelele to edit keyboard layouts in OS X if there is no suitable one by default.

share|improve this answer
Thanks, this pointed me in the right direction – Liam Feb 6 '12 at 15:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .