Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to cleanup the following error message:

pdf-reader /home/jseidel/ebilling_1393100.pdf
Traceback (most recent call last):
  File "/usr/lib/command-not-found", line 10, in <module>
    import CommandNotFound
ImportError: No module named CommandNotFound

which is apparently caused by a python problem (see http://ubuntuforums.org/showthread.php?t=1380441). I recently tried to upgrade to python7.2 because of a dependency from poppler. However, the instructions suggest doing a sudo apt-get dist-upgrade but I don't want to upgrade my distribution - I'm on Kubuntu 10.04 and don't want to introduce and instability into my system.

I read on another post that dist-upgrade wouldn't automatically take you from and LTS version (10.04) to another release but since there are subsequent LTS distributions to 10.04, I'm hesitant to run that command (I've read the definition of dist-upgrade and it sure isn't clear to me).

Thanks...

Any suggestions?

share|improve this question

migrated from stackoverflow.com Feb 6 '12 at 15:53

This question came from our site for professional and enthusiast programmers.

add comment

1 Answer

up vote 1 down vote accepted

As you'll see in the manual page, dist-upgrade doesn't necessarily mean distribution upgrade. Sometimes it just means remove some packages and install other ones to fix conflicts that prevent the system from upgrading completely:

dist-upgrade

dist-upgrade in addition to performing the function of upgrade, also intelligently handles changing dependencies with new versions of packages; apt-get has a "smart" conflict resolution system, and it will attempt to upgrade the most important packages at the expense of less important ones if necessary. So, dist-upgrade command may remove some packages. The /etc/apt/sources.list file contains a list of locations from which to retrieve desired package files. See also apt_preferences(5) for a mechanism for overriding the general settings for individual packages.

My advice would be to run the command and check what is going to be installed/removed. If agree on the chagnes, then press Y, otherwise press N. Even if you make a mistake and the distribution upgrade tool starts gathering information, you can click on the cancel button without actually making any change, so just running the command shouldn't cause any problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.