Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The following steps were made to access files in a folder that was created with Macrium Reflect on a Windows 7 64 Bit system.

You don't currently have permissions to access this folder. You have been denied permission to access this folder. You must have Read permissions to view the properties of this object. Advanced Security Settings for Admin

In the last dialog I could change the owner and the permission but the mounted volume is write-protected so I cannot close the dialog and apply the changes.

I just want to read them. What do I do?

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

I'm a developer of Macrium Reflect, so big disclaimer here, I am talking about a product I am professionally involved in.

Our image mounting code (right click, mount volume) does not allow you to write to your backed up image at all - this includes making changes to the NTFS metadata that allows you to alter file permissions.

However, we're aware that causes problems for folders for which you do not have permission; luckily we've got a workaround for that. From our knowledgebase:

The option 'Enable access to restricted folders' will mount the image with full NTFS access rights to all folders in the image. This enables you to fully browse images that were created on another PC where otherwise some folders may be inaccessible due to NTFS security restrictions.

To enable that option, select the checkbox on this dialog:

Restricted folders dialog

We essentially override the NTFS permissions for folders you cannot access. If you make sure you check this when accessing your image you should be able to access everything.

share|improve this answer
1  
Thank you very much, this works. –  gentlesea May 4 '12 at 5:45
add comment

If you don't have permission to read it, and you can't modify the permissions (because it is write protected), then this is impossible.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.