Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The title is kind of self explanatory, as my new laptop lags and has FPS drops. For example my FPS in Starcraft 2 hovers around 20 and constantly drops to 1 with low settings when I know it should run smoothly in high settings. I've updated my Nvidia driver, and set the preferred global settings to the 'High-performance Nvidia processor'. Here are some screen shots.

Screen Shot One - Screen Shot Two - Screen Shot Three

I'm not sure how to fix this problem, any feed back would be nice!

share|improve this question
Laptops are prone to overheating. Try installing the CPUID HWMonitor and play the game while it's running. Then take a look at the max temperature (right column) of your GPU. – Dennis Feb 7 '12 at 3:04
Something makes me wonder if your switchable graphics is working properly. Typically this is handled by the Nvidia drivers but I have come across a few models (Sony and an Acer) that have a hardware switch. Have you looked into that issue? dxdiag is only showing the Intel HD graphics core on your i5... – Dustin G. Feb 7 '12 at 3:24
possible duplicate of Intermittent massive graphics slowdown (25fps->1fps) – Ƭᴇcʜιᴇ007 Feb 7 '12 at 3:43
Wow, thanks for quick the replies guys! I downloaded and checked with CPUID & GPUShark when my game is running, but I'm not sure what exactly I'm suppose to be looking for. Also I'm not too sure why dxdiag displays my Intel HD and not my NVIDIA, it is kind of the same with device manager. It doesn't say I've updated my driver either. – Calvin Feb 7 '12 at 5:59
@Calvin - It should say "State 0". That's the highest power state available. – Shiki Feb 11 '12 at 15:06

You can get some really valuable information out of your card(s) with GPUShark. For example the power level. If it's not on Power level 0 when you play, you should check out this little app:

It lets you adjust the power management settings for your nVidia card. (My card would never run on power level 0 before this application.)

share|improve this answer

Also check to make sure your CPU isnt throttling due to heat.

You can download throttlestop to force your cpu to keep up the turbo just watch the heat.

Also make sure the laptop is plugged in while gaming.

share|improve this answer
More of a comment than a full answer. – Hennes Mar 8 at 20:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.