Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to use Irssi client to connect to irc.freenode.net in my office. What is happening is I think our corporate firewall is blocking IRC ports.

Can anyone tell me how to get around this. I'm just trying to do some nodeJs development and need to connect to their channel #node.js to get support.

Please help.

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

if port 22 is not blocked, you can use ssh to connect to your home computer, and then use irssi on that machine. or you can try freenode's web client http://webchat.freenode.net

share|improve this answer
    
Thanks mate. I was thinking anything other that the web version. Anyway that will work. Is there no other way to make this work. –  Soham Dasgupta Feb 7 '12 at 7:11
add comment

Well, I'd first advise you to make sure you're not in breach of any corporate IT policies when you try to go around the firewall.

If you have a *nix machine at home you should be able to ssh to it, find an open port, have sshd listen on that port and then either ssh to the machine and run Irssi there or create a tunnel so that you can connect to that port on your home machine and have the connection forwarded to the Freenode servers.

Another possible option would be to ask for the necessary port(s) to be opened by your IT department.

Or, if you have a smartphone, tether it to your computer and use that connection to connect to Freenode (IRC isn't exactly high bandwidth so unless you have a very limited plan for your cellphone you shouldn't have any problems there).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.